ZIP/TR-3 problem



New Member
Responding to Rottie form another thread he writes;
Also I can't get ZIP drive disabled from BIO in order to have Eagle TR-3 tape drive to work.
When I had AMI Flash BIO on same mobo and ZIP drive was set to drive G: and Eagle TR-3 was set to drive B: it works just fine and from the ZIP manual says to disable ZIP drive on BIOS in order to work properly.
Now I was told by mobo to upgrade to Award BIO using flash bio upgrade now ZIP and TR-3 does not work right..Zip becomes drive B; TR-3 could not be set to any drive letter.
I believe the Award Bio I have right now is version 4.51 and PNP bio version 1.0

Rottie: What operating system are you using? How is your tape drive and zip attached to your system? Is either the older kind that connects to your floppy controller or are they connected to IDE, Parallel, or a SCSI card. If either is connected to a SCSI card is it a legacy card where you had to set jumpers? Have you checked for resource conflicts? My guess is that if I can’t, someone here will be able to help you.
good luck.


New Member
Ok I am using Windows 98 and TR tape drive cable is connected to floppy controller built in on the motherboard with 3 1/4 drive.

There is no jumper on TR drive and no IRQ conflict on both ZIP and TR drives.

Zip drive is set to slave with CD drive as master using secondary EIDE controller on the motherboard.

Also I have two hard drives on primary EIDE controller on the motherboard C: as master and D: as slave....

Did I do the right thing? Then ZIP is operated just fine as drive B: but it is not what I wanted. I did tried to change drive letter for ZIP drive from device manager but it is greyed out.

So....what should I do?


New Member
OK Rottie few more questions.

1.Did this problem surface when you flashed bios, or when you tried to disable zip drive in bios?

2. You said zip drive was set to drive G, what is drive E & F assigned to, do you have partitions assigned drive letters on C or D.?

3. What are your bios settings for: secondary slave? Drive B? PnP Operating system?


New Member
I’m answering my own post now, Rottie I probably will not check the bulletin board until latter tonight.Here is what I would do, and you may want to wait for a while to see if there are more posts with other solutions.

Set bios to PnP OS = No, Secondary Slave = Auto, Drive B = Auto or none if there is no similar option.

Go to device manager and remove both the TR-3 and the Zip drive.

Go to add new hardware and let windows search and reinstall both drives.

I can see no reason why you need to disable your zip drive for your tape drive to work properly as long as tape drive is on floppy controller and zip is on secondary slave. However you could not access drive A while using your tape drive.

Good Luck!

[This message has been edited by RONB (edited 05-17-99).]