XP Drivers for Toshiba Laptop

E

eggdashure

New Member
#1
Hi all,

I just got a new Toshiba Satellite A135-S2306 Laptop that had Vista pre-installed. I can't stand Vista! I was one of the many beta testers that Microsoft didn't listen to. :mad: Anyways, my wireless connection kept dropping, I dug around and updated drivers but nothing made a difference. I finally lost all patience when I was writing a discussion for a college class and as I was sending the connection went bust and I lost an hours work.

Anyway, I re-upgraded back to XP and haven't been kicked once yet. Plus, all my programs work too! So, now I have a new problem, my ati card drivers won't work, they were designed for Vista. Does anyone know where I can find XP drivers for this system? Toshiba is not returning my calls.:eek:

Missing Drivers:

Modem Device on High Definition Audio Bus
SM Bus Controller
Unknown Device (Looks like ACPI Controller)
Unknown Device (Same)
Video Controller (VGA Compatible)

Matt


NOTE: Number of posts moved into separate threads according to specific Toshiba/Satellite models.
- Moderator
 
E

eggdashure

New Member
#4
The system shipped with Vista Pre-Installed, so I used my own XP disk to revert back. But, for some reason I guess Toshiba doesn't want people to go backwards, no drivers that I can find.

As far as those ATI Drivers, I downloaded the exact file your link shows and it says the drivers aren't supported by my system.

This has me really stumped. Maybe Omega drivers? Or is there a auto detection service for ATI Chipsets?

Thanks!
Matt
 
Shinma

Shinma

____________
#5
If model stated by you is correct,
You can try the PC Wizard software to see if it identifies the chipset/components making up the laptop.
 
E

eggdashure

New Member
#6
PC Software Wizard? Through Windows? I did double check the numbers on Toshiba's site and doubled checked the bottom of the laptop. It is A135-S2306 with Graphics Chipset : Radeon® Xpress 200M. Still nothing. :confused:

I've been bumming around Toshiba's site for the better part of an hour and can't find an E-mail for Tech Support. Does anyone know if it exists?

Thanks again,
Matt
 
Shinma

Shinma

____________
#7
PC Wizard download/link and other utilities is listed in Various DOWNLOADS thread, located in the General Forum.

Toshiba listed contact info.

Toll-free Technical Support

* Computers: (800) 457-7777
* PDAs: (800) 949-7993
* Projectors: (877) 523-8324

Also available is the Laptop Computing Forum on CompuServe. Though you will be required to set up a screen name, this service is free, and offers peer-based assistance with your Toshiba or other portable PC.

Online Technical Support through Ask Iris® Online

Sales Information: (800) TOSHIBA

Toshiba Financial Services: (800) 207-8362

Government and Education: 888-9-PUBLIC (782542)

Customer Service: (800) 457-7777

Address:
Toshiba America Information Systems, Inc.
Computer Systems Division
9740 Irvine Boulevard
Irvine, CA 92618-1697

Corporate Offices (949) 583-3000
 
V

VistaResistor

New Member
#9
Vista SUKS

I have this same problem and I have played for a long time... I have found that MOST of these problems can be delt with by just simply going through and using the Toshiba Utility on your vista rescue disk and HAND PICKING what you install. I have every thing up and working and I stil have 4 exclamation points. the only real issue in performance is that it hangs up intermitantly while web surfing and then continues. I am thinking some sort of IRQ conflict? any help??? But all of the sound and video is for sure on that disk along with the wireless driver and ethernet and modem....
 
Last edited:
V

v307753

New Member
#10
A135 Hanging Issue

Hey, Vistaresistor...I am also having the 'hanging' problem on IE. I noticed it after installing the sound driver off the vista install cd. I reinstalled it and it seemed to clear for a little bit but now is back. It is extremely irritating. Reminds me of the 'dialup' days. Did you happen to find a fix?

My husband and I both backleveled our A135s since our work network doesn't support Vista yet. He went to W2k. I went to XP. His isn't hanging like mine.
 
Last edited:
E

ewave

New Member
#11
xp drivers for toshiba

VistaResistor said:
I have this same problem and I have played for a long time... I have found that MOST of these problems can be delt with by just simply going through and using the Toshiba Utility on your vista rescue disk and HAND PICKING what you install. I have every thing up and working and I stil have 4 exclamation points. the only real issue in performance is that it hangs up intermitantly while web surfing and then continues. I am thinking some sort of IRQ conflict? any help??? But all of the sound and video is for sure on that disk along with the wireless driver and ethernet and modem....
Please tell how and exactly which drivers you got for sound and video.
I haven't been able to find this on the backup cd
regards

ewave


jasinwa said:
I am not having any hang problems, did not use drivers from Vista (although I'd love to get the 2 unknown acpi drivers fixed....still can't control my brightness with buttons.).

I am at work bu if interested, I could post a large zip on my site. I have a a135-s2246 (lower end model) but I trust the same drivers?
please post...what is your site?

thanks
ewave
 
Shinma

Shinma

____________
#12
ewave said:
Please tell how and exactly which drivers you got for sound and video...
Until VistaResistor gets back to you,
You can try Groovy Mojo's suggestion of using the:

Video/Radeon Omega drivers.
Available at the 3D Accelerator's website,
Check out the following link:
Click HERE

ATi 200M/Southbridge drivers,
Click HERE


madcow007's suggestion of using Toshiba Satellite L30 drivers,
Since it too has the ATi 200M chipset:

Video/ATi with chipset drivers,
Click HERE

Realtek audio drivers,
Click HERE

Hotkey utility,
Click HERE

Realtek LAN,
Click HERE

Atheros wireless LAN,
Click HERE

Intel wireless LAN,
Click HERE

 
A

alexmiami

New Member
#13
Found ATI and Audio driver, however not Wireless Driver

Guys,
Thanks for your help the Omega drivers worked .now my ATI is ok, as well as the audio drivers;however, the wireless drivers can't find it.. any help.
I went to toshiba http://www.csd.toshiba.com/cgi-bin/tais/su/su_sc_modSel.jsp . I downloaded the drivers for wireless for Atheros Wireless LAN MiniPCI card Driver and istalled but it's dosen't work. I check and my wireless switch is ON.. Any help... is the only driver i have missing
Thanks
Alex


please let me know if you found the wireless driver... i have found all of them but not the wireless
thank
alex
 
M

metabaron

New Member
#18
bubamara, did you find the drivers for the 2 unknown device working? How bout anyone else?
 
P

Perce

New Member
#19
I also "had to dig" for 3 Toshiba Laptop conversions, this thread was helpful. Good job guys and girls :)
 
A

amylopan

New Member
#20
Forgive me for a silly question, as I'm not a technical person at all. The download everyone is using for the XP drivers... if I want to downgrade my A135 from Vista to XP, will I have to get an XP program PLUS that download with the drivers or will that download have everything on it for me?

Maybe I shouldn't be trying all this at all, but I'm desperate. I have a brand new computer I just want to throw out the window- Vista ****s! I've asked several IT guys to do this for me and they won't/can't. Geek Squad told me they wouldn't do it b/c Vista is *clearly* the superior system! WTF?!

Am I going to have to run out and buy XP now to downgrade the computer? I've buried so much money into this damn thing by upgrading the RAM (still didn't help) and three weeks after purchase, the LCD backlight went out! AGH! How much will XP set me back now?

:(
TIA!