VIA-530+ and LinkSys Ethernet Network Problem

B

bserviss

New Member
#1
I have two computers at home and wanted to network them together. I bought the LinkSys Ethernet starter kit and installed the hardware into my two computers. The systems are a P166 (winchip upgrade)running Win95 and a AMD K6-2 350 running Win98 with the subject motherboard. The network installation on the P166 went off without a hitch. The installation of the network card on the K6-2 computer didn't work. The system would detect the card, install the software but during the next re-boot the start-up screen would remain on with the color bar along the bottom moving like a normal boot-up, and remain this way.
Any ideas?
I've emailed LinkSys twice with no response - so much for the PC Mag endorsement right?
 
E

Eccentric

New Member
#2
Where did you get the Win98 from? Although this may not apply to you I had the exact same problem on a Pent MMX with Win98 upgrade. I had a 3com combo ethernet. When I installed it Win98 upgrade would not boot, stuck at the bar moving screen. However, when I went into safe mode, and uninstalled the card, it would boot fine. My solution was to get rid of the upgrade, and use a FULL installation on 98 and it worked fine.
 
A

aab101

New Member
#3
Hi--I posted this as a possible solution to someone else's problem yesterday, but I think it might also be your problem. In fact, I had a similar problem with that same mobo, Win 98, but a different PCI nic (Samsung). I suggest you try disabling IRQ steering to see if that fixes it. It seems that although some new mobos support it in conjunction with Win 98 (or Win 95 with OSR2 I think), there are PCI nics out there that don't "like" it. IRQ steering allows the machine to put multiple PCI cards on a single IRQ (when it works). To disable it go to: Control Panel/System/Device Manager/System Devices/PCI Bus & disable IRQ steering (3rd tab). There's also a website you might try:
www.helmig.com
Good luck!
 
W

warezdaman

New Member
#4
resource sharing might be the problem, but I have only encountered this problem with 3com 90xx series, where I replace it with a linksys or Intel nic the problem goes away, so I don't think it is a resource sharing problem , more likely you and stomping on an already allocated IRQ or i/o that cannot be shared (used by isa component possibly).Try removing other peripherials one at a time, or try another PCI slot.
 
B

bserviss

New Member
#5
Thanks for all the suggestions. I did a total re-install of Win 98 with the board installed and it worked - sort of. I then disabled the PCI steering as descibed above. Now the network is up and running. Thanks for the web page too, it has a lot of good info.
LinkSys still hasn't replied yet....
 

Associates