Unreal(v225)/Unreal Return to NaPali Advanced Options: Game freezing

Mephisto

Mephisto

New Member
#1
Hi,
Lately I installed both games, and they run pretty well in D3D in 1024x768x32. But everytime I choose the Advanced options in the menu, the game freezes. All I can do is minimize it via Strg+Alt+Esc and then kill it via task manager.
That doesn't happen in Software Rendering mode.
I don't have any other problems with games.
System specs T-Bird 1.3 GHz, Windows ME, 256 MB PC133, Elsa Gladiac 32 (GF2 GTS) and Detonators 12.41.
Any suggestions? Thanks a lot!
 
equinoxe3d

equinoxe3d

Active Member
#2
Go into the Unreal.ini, and in the [Engine.Engine] section, make sure that the
WindowedRenderDevice option is set to SoftDrv.SoftwareRenderDevice. Also set the WindowedViewportX at 640 and WindowedViewportY at 480 under[WinDrv.WindowsClient]. I got a similar problem because the hardware acceleration wouldn't kick in windowed mode (required to access the Advanced options) after dropping from fullscreen. Hope it helps!

[Edit: if the windowed mode is already set to software rendering, you might want to set it on D3D by putting D3DDrv.D3DRenderDevice instead.]


------------------
EquinoXe's old baby:
Pentium II 350 MHz
192MB Nec/Infineon PC100 SDRAM
6GB Fujitsu HDD (Ultra33)
Voodoo3 3000 AGP
Guillemot MaxiSound Fortissimo
Creative 36X CD-ROM
Windows 98SE


[This message has been edited by equinoxe3d (edited 08-18-2001).]
 
Mephisto

Mephisto

New Member
#3
Thank you very much, equinoxe3d!
I already had been playing around with the viewport and rendering settings, but it didn't find a combination that solved the problem.
Now I found the game doesn't exactly freeze, as I said in my initial post. What exactly happens is this:
When I choose Advanced options, the game stays fullscreen, but the screen is tiled into several sections. One of the sections has the size of the windowed viewport and contains a smaller version of the complete game-screen. Behind these sections I can barely see the Advanced options window flickering, which I then can close via Alt+F4. After that I can access the game's menu like before, sometimes fullscreen, but sometimes the tiling stays, and the game runs in the smaller windowed viewport section (in D3D, although I had set the windowed rendering mode to software). Strange!?
 
equinoxe3d

equinoxe3d

Active Member
#4
Well, it may be a driver problem then. I would get a fatal error when attempting to access the Advanced options with hardware accelerated windowed mode. Maybe trying another driver set, or run the game in OpenGL could help?



------------------
EquinoXe's old baby:
Pentium II 350 MHz
192MB Nec/Infineon PC100 SDRAM
6GB Fujitsu HDD (Ultra33)
Voodoo3 3000 AGP
Guillemot MaxiSound Fortissimo
Creative 36X CD-ROM
Windows 98SE
 

Associates