[RESOLVED] Weird WOL issue

dannyboy27

dannyboy27

Lazy
#1
Hey guys,

Let me stress first of all, that I've been using WOL (wake on lan) on my home PC for about 3 years, with no problems whatsoever. Recently however, it's stopped working and I have no idea why.

I haven't made any hardware or software changes to the PC, but it was unplugged from the mains for about a week while we redecorated the room it's in. When I started using it again, I found that WOL only now works for a few minutes after the PC has been powered down. Leave it more than 5-10 minutes and the WOL packets do nothing.

I've used a packet sniffer to confirm the WOL packets are reaching the PC and signalling the correct MAC address. And the fact that WOL works at all must mean these settings are correct. Wake On PME is enabled in the BIOS, and wake on magic packet is enabled in the NIC properties.

In the Power Management tab, I've got all 3 boxes ticked as per screenshot (which is how I've always had it configured). I also had a quick google around to confirm these settings are correct.

Up to now I've been using the onboard Realtek NIC, but I even tried fitting a new PCI card yesterday and that's exactly the same - only works for a few minutes after shutdown.

I even tried clearing CMOS no to avail. So at this point I'm completely stumped. Anything I might've missed that anyone else can suggest?

thanks
Dan

edit: system specs in my sig

 
dannyboy27

dannyboy27

Lazy
#3
That was my first thought too, as having that option enabled seems counter-intuitive. But if you untick it, it greys out the other two boxes, and after a reboot the option 'allow this device to wake the computer' has unticked itself too. (and you can't re-tick it because it's greyed out!).

I found the problem last night in the end - it turned out to be my DDWRT router had lost the static ARP entry I'd configured to point it to my NIC's MAC address. So a few minutes after my PC was shut down, the router was clearing its ARP cache and forgetting the MAC address of my NIC.

Don't know why the router lost the static entry but I've re-added it now and all is good. It was just unfortunate coincidence that the problem occurred around the same time as my PC was unplugged for a few days, as it meant my initial suspicions were with the PC.

thanks for the reply anyway
 
nodnod

nodnod

Dismember
#4
Having worked in DSL tech support for several years I can say that your router just losing information isn't unusual. Routers suck but are a necessary evil

P.S. Cisco based routers seem to be among the top offenders
 

Associates