[RESOLVED] Keyboard Layout Issue with Thinkpad

W

wetling

See my Sig
#1
I received the following e-mail from someone I know. I know I've solved this before, but I can't remember. Does anyone know?

When I take my laptop out of the dock it reverts to the funky alternate keypad numbers working on the letters – for example, M becomes zero, etc.
Thanks
 
MuFu

MuFu

Moderator
#2
Try Shift + ScrLk.

Not sure about stopping it happening in the first place though, sorry - must be in the IBM software somewhere I'd imagine.
 
ThreeOnTheTree

ThreeOnTheTree

New Member
#3
Sounds like you have "numlock" on. And no, that's not an insult. It's a setting that allows you to run the number keypad on a laptop keyboard using designated letter keys.
 
W

wetling

See my Sig
#4
Yeah, but why would the numlock only be engage only when the machine is disconnected from the dock?
 
ThreeOnTheTree

ThreeOnTheTree

New Member
#5
Good question. Maybe when the machine gets pulled out of the dock, the button gets hit by mistake? Does IBM say anything about the issue?
 
M

Maddie

New Member
#7
Help! Thinkpad keyboard issues!

This thinkpad was given to me by a friend and I am on the road with it for the first time, and I cannot get the regular alphabet back. It is using alternate keys - the calculator number set-up which alternates some of the letter keys. For instance, I type a "u" and get a 4. I don't know my commands well for this machine and tried the shift + scroll-lock mentioned below. It did not work. Also, I am able to turn num lock off and on but this does not affect the alternate settings.

Any ideas? I am on a deadline and need this machine. I am sending this to you from the hotel's business center and it is costing me a fortune!
 
Hoyle

Hoyle

New Member
#9
Have you tried the "Fn" key combinations? I used to have a T42 a while back and the way to enable/disable the number-pad feature was something like Fn+Numberlock. I can't recall exactly, but it DEFINATELY had to do with the Fn key.
 
A

anibus

New Member
#10
solution

I had the same problem and was driving me crazy.
shift and the numberlock/scroll lock:)
 
mnair99

mnair99

New Member
#11
Thanks MuFu, Shift + ScrLk worked for me and i'm typing using the same keyboards, hardly minutes ago i had this problem..

Thanks again for the post & the reply..

cheers, Murali..