Reinstalled XP will not read a previously installed second 300gb drive



New Member
Win XP Home / SP2 / 2.6 GHz Celeron /1.5 GB DDR RAM / Intel 845 chipset.

I just did a routine reformat and reinstallation of Windows XP Home. This was the first reinstall since I added a second 300gb storage disk.The Boot HD has 120GB (WD1200BB), the second one has 300GB and is only used for storage. Both are Western Digitals. The storage drive (D) (WD3000JB) had 260GB of data on it prior to reinstall. Both drives were NTFS and fully operational before the Windows reinstall. After I reformatted and reinstalled windows XP on Drive C and rebooted, I can no longer get access to my 300GB drive. When I click on the drive in Windows Explorer, Windows prompts me to format the HD. Further, the drive properties now list the drive as being in RAW format with zero used/free bytes. Disk management sees the drive but also prompts me to format the drive. It says the file system is unidentifiable. How could it change? Win XP now has had all updates and service packs added since the reformat/reinstall. The drive DOES show up in the BIOS as a 300GB drive. I have run diagnostics on the drive and it is mechanically sound. I used the WD Data Lifeguard Tool to install the support for 48 bit LBA for ATAPI disk drives. It shows up in the registry but has not helped with the problem. I disconnected the second drive and REINSTALLED windows again, got all of the updates and then shut down and booted up with the new hard drive. Still no success. If I continue with the Western Digital Data Lifeguard Tool, it wants to erase the 300gb disc with a subsequent loss of data. How did I lose my file system? PC Inspector reports a "Bad parameter in boot sector". What do I need to do to get Windows to access the second drive without losing the data or am I now out of the "rescue" stage and into the "recovery" stage?


If possible, try another PC. You might have to use a recovery utility to get the data. Sounds like the boot sector has been destroyed. Try Testdisk , Go in Advanced, Boot, choose BackupBS, Quit and restart your PC. You might be able to access your disk, its worked for me in similar situations.