Problem with ASUS X205TA with embedded 32GB eMMC or when to know if/when eMMC HD is going bad?

O

ol' man

workin fingas to the bone
#1
I have been working on a ASUS X205TA with a quad core 1.33GHz ATOM processor and an embedded 32GB flash/eMMC HD. It originally had win8.1 32bit but it crashed so I thought to upgrade to win10 32bit. It is a 64bit CPU but ASUS uses a 32bit UEFI so only a 32bit windows OS can be installed. I first wiped the drive with the diskpart "clean" command in WinPE DOS and the install went great. It booted three times and was working great then suddenly the bootsector got corrupted on a fourth boot. So I tried all the fixboot, bootrec... etc.. commands from WinPE DOS to no avail. So I got the idea to wipe it again and reinstall again..... Thats when all the trouble started.

The first thing to know about this netbook is that it has a partition or partitions in something called RPMB or Replay Protected Memory Block. Removing these partitions has been futile and it would appear they cannot be removed. I have been able to clone them with clonezilla but I have not delved into what is in them yet if anything. The BIOS has a special setting called secure erase which I have used to also wipe the drive along with the diskpart "clean" command in WinPE DOS.

Long story short the diskpart clean command on the second try did not wipe the drive but only made the partitions inaccessible. The only way I was able to remove them was with the bios secure erase setting. But it did not erase the two 4mb RPMB partitions. Now I cannot create partitions on this drive at all and win7/8/10 (I tried them all) errors out with a 0x803000002 code. It just says the drive is unallocated and it cannot be allocated and M$ cannot be installed on the drive.

I also tried turning off the RPMB provisioning setting in the bios with no luck either. Downgrading the eMMC controller to 4.41 from 4.5 did not work either and made the drive disappear in the UEFI shell. Apparently this RPMB is completely write/erase protected. I am not even sure this is the problem. I am thinking that the eMMC flash is bad or wore out after too much use or just went bad. Also you cannot install to a USB drive and the SD card reader does not show up with a 32GB card as a viable install location either. I have tried to clone a 32GB install into the eMMC drive and that is not working either.

Maybe there is a linux bin or something that can tell if the eMMC is going bad?

This has been a major PITA. This is only the second time I have had to mess with embedded eMMC HD's soldered to the board. Personally I think they are BS cause you cannot replace it very easily.
 
Technoplume

Technoplume

Member
#3
Hi, I might be wrong, but the RPMB partition is normal on a SSD. This is where address of failed bits would be redirected when they stop working. Every SSD has a quantity of reserved space to reroute bad sector to a new section of the drive. If you deleted that partition, then the Bad sector where put back in service and then you got corruption. Has the SSD don't know where to put the information any more.

I would try to look up on the manifacture web site for a tool to reset the factory partition, Then maybe it has a scan tool so it can test each sector and reroute bad sector.

Or just buy a new SSD.
 

Associates