Please help...Windows XP SP3 setup hangs/freezes at 34 minutes



New Member
i am trying to install windows xp service pack 3 onto my Acer Extensa 5510 notebook laptop for the last 48 hours...but seem to fail every time. There was an 80gb hard drive in it already but the windows on that kept freezing every time it loaded to a state where i couldnt even move the mouse, was working perfectly fine before, so i decided to install a brand new 200gb hard drive so i can store more of my work in it. Once installed, i inserted the windows xp sp3 disk, and formatted the hard drive to ntfs (quick) and then the files started to copy, once that was done, it restarted and the actual installation part started. it went from 39 minutes down to 35 minutes and froze on the installing devices part. i thought it was a common error so i restarted the setup. this time it went to 34 minutes and froze. i restarted setup again, and it went all the way down to 8 minutes and froze. i restarted the setup one more time, and it got stuck on 35 minutes. for the rest of the day, most of the times it would get stuck on 34/35 minutes and either froze or restarted the laptop for no reason. Only once, it went down to 23 minutes and froze. only 2 out of 30 tries went past the install devices section.

The specification is as follows:

Model: Acer Extensa 5510
CPU: Intel Core 2 Duo 1.66ghz
Hard Drive: 200gb SATA
RAM: 1gb
15.4" screen and built in wireless

i will give a more detailed specification in a few hours, as it is dark right now and the laptop is in a room where there are people sleeping :(

someone please help me out...really need to get coursework done this holiday and hate going local library as i only get one hour max there to use a computer

your help will be much appreciated and will remember you always as the one who helped fix my laptop :D


New Member
hi Midknyte :)

yes it has the windows vista sticker on it, so i am guessing it originally had windows vista, but wen i got it, it had windows xp sp1 on the 80gb, and i am trying to get my hands on a windows vista install disk right now.

I also saw that link earlier today, and the funny thing is, in the setupapi.log file, it always said a different .inf file was causing a problem each time i restarted the setup. i think one of them was a cpu.inf file...and another was to do with the audio. i didnt bother deleting the cpu.inf one because i read in the comments that it was the drivers for the cpu and was an important system file for the setup. i will try the same method again in a few hours and will post the results.

Thanks again :)


The notebook may be configured to run via AHCI.
Windows XP does not natively support AHCI.


Caffeine Fiend
As Shinma stated, the bios may be set to AHCI for the hard drive. Set them to IDE mode.


New Member
Thanks for the support. I couldnt find anything to do with the AHCI in my BIOS so i have listed all the options in BIOS below so if anything needs changing, let me know.

The options i have in bios are...

Page 1 (Information) shows information about the notebook, cpu type, cpy speed, hdd model name, hdd serial number, atapi serial number, BIOS version, VGA BIOS version, serial number, Asset Tag Number, Product Name, Manufacturer Name, UUID Number.

None of these values can be changed.

Page 2 (Main) shows System Time, System Date, System Memory (640kb), Extended Memory (1023mb), Video Memory (64mb), Quiet Boot (Disabled), Power on display (Auto), Network Boot (Disabled), F12 Boot Menu (Enabled), D2D Recovery (Disabled).

System Time and Date have been checked twice and are correct. System Memory and Extended Memory can not be changed. Video Memory can be changed to 128mb or MaxDVMT. Quiet Boot can be enabled. Power on display can be changed to "Both". Network Boot can be enabled. F12 boot menu can be disabled. D2D Recovery can be enabled.

Page 3 (Advanced) shows Infrared and i have it Disabled. I can not enable it, the sub menu does not open.

Page 4 (Security) shows Supervisor Password, User Password and HDD Password are all clear. I can add a supervisor password or HDD password, but not a user password.

Page 5 (Boot) shows the boot order which is in this order: HDD, DVD, USB FDD, Network Boot, USB HDD, USB Key, USB CDROM.

Page 6 (Exit) allows me to exit saving changes, exit discharging changes, load setup defaults, discard change or save changes.

Are there any values i should change?


New Member
Full Specifications are:

Intel Core 2 Duo Processor T5500 (64 bit)
(1.66ghz, 667mhz FSB, 2mb L2 Cache)
15.4" WXGA Acer CrystalBrite LCD (16ms)
Intel Graphics Media Accelerator 950
DVD +/- RW drive
200gb Fujitsu Hard Drive
1gb DDR2 RAM, (2x 512mb sticks)
Built in 802.11 a/b/g wireless Lan

there is also a bluetooth switch at the front, but it does not light up, so i am guessing a bluetooth module was not installed.

Also, the BIOS version is 3.50, the latest version is 3.60 but i can not install it because i need windows to install it.

Any more information needed can be provided. :)


New Member
I have just got my hands on a windows 7 install disk and started the setup, and it got stuck at "expanding windows files" at 54%. When i restarted and tried the setup again, it hanged at the "Starting Windows" screen with the logo. On trying a third time, it got stuck at 68% also at "expanding windows files".

Any ideas why this is happening?

Thanks again. :)


Caffeine Fiend
I'm assuming these are genuine Windows install discs. If they are copies, all bets are off.

What happened to Vista and the recovery discs?

Did you do any ram diags? I know you swapped hard drives, but did you verify that they are good also?

That BIOS is pretty sad. I would tell you to disable things like audio and usb flash card readers until Windows is installed, but you don't have those options.


New Member
(sorry for late reply, memory diags took ages)

Yes all the windows install disks are genuine. No copies.
When i try to load vista, it gets stuck at the green bar after the "windows is loading files" bit. this happened with all 3 of the install disks i have and also same thing happened with the recovery disk provided with the laptop (also vista).

The ram diags show there is nothing wrong with the ram and i also tried with other ram sticks but the same thing happens.

I checked the hard drive for bad sectors and there werent any. I also tried with another hard drive and same thing happened.

I also tried setup with another processor and still same thing happened.

On the other hand, i took the hard drive out of my old pentium 2 laptop which had windows xp sp3 installed, put it into this laptop and it loaded windows but after 5 seconds it froze (note: the drivers had not started to install yet). this happened each time i restarted. I then booted into safe mode and it worked flawlessly without any problems. About 50 drivers installed and was working perfectly. But then i restart and try booting into windows again, it froze. (i also have another hard drive with windows 7 ultimate 32bit, put this into the laptop, booted to windows and it froze, booted to safe and it worked perfectly.)

Any ideas why this is happening?

Thanks again for helping :)