HELP!!! DStealth III S540 PCI won't work on NT40



New Member
Just got a purchased a 32MB Diamond Stealth III S540 PCI Video Card. It won't bloody run on my PC with Windows NT 4.0 + Service Pack 5.
Here's the story...
Before I installed the card into my PC, I set the video card drivers to a "standard vga compatible" driver as recommended. Then I installed the card. What happens is when I install the drivers and reboot the PC, it won't boot up. It stops just before the Windows NT logo should appear on the screen and then should ask you to press CTRL+ALT+DELETE to log on BUT it just displays the standard aqua blue background colour and... NOTHING no hard disk activity from there on. It boots up OK in "SAFE MODE" but not in "NORMAL MODE". I ask why is it so??? When I change the driver back to "STANDARD VGA COMPATIBLE" it boots up as normal.

OK I've tried old/new drivers, same problem.

I've tried removing all cards except for DIAMOND card and then removing/re-installing frivers...same problem.

I've tried disabling/enabling/tweaking different features in cache, S.M.A.R.T., Power Management, PnP, etc...same problem.

I've tried an el-cheapo 4MB PCI SiS Card. It works fine. No problems installing drivers,etc.

I've tried installing the card on a PC running Win98. No problems there. So the problem is not the card itself.


Any suggestions??? I'd really appreciate your input.



New Member
Sorry about bringing up an old post, but I am experiencing the same problem, and Diamond tech support says they can't help. Does anyone know the cause of this problem, I too have tried the card in another machine running win98 and it works fine. My system is:
Asus P5A
AMD K6-2/400
Compaq NC3121 NIC
Diamond Stealth III S540 PCI Version 32MB

Any help would be extremely appreciated