External HD Issues (Maxtor/Kingwin)



New Member
Good Day Everyone,

I am pasting a post I submitted to another forum and have not yet gotten any response. The data recovery scan will complete today, and am concerned that today's recovered data along with that from a previous problem may go south.

The recovery destination drive is in Comp 2, see below, on a WD 200gb SATA formatted Fat 32, on a sabrent I believe pci sata controller card (lost data when connected to the on board sata promise fastrack deal single drive array on the MB, so went with the pci hoping it would be more stable)

I have looked around and am both confused and stumped, not the brightest bauble in the bowl I'm afraid.

I am also concerned about the internal SATA as is on the machine (Comp 2) where the externals have gone awry. Think maybe a LBA issue in windows? as the loses have occurred on 200gb hd's formatted into single partitions, so far no probs with large drive formatted into multiple partions under the 137gb? limit.

I'm reluctant to use the maxtor big drive patch, the windows hotfix,or edit the registry in fear of losing data again, and am not certain this be the prob.

below is the post mentioned above...hope someoneknows what is the cause of my woes, and or can advise how to determine what is causing it, w/o risking the recovery drive (can always unplug it) Thnx In Advance: Prole

" have experienced problems with data going missing in my external hd's.
I am using KINGWIN 3.5" USB MS-350U-BK: http://www.newegg.com/Product/Produc...82E16817146312

And Maxtor Diamond Max Plus 9 (both are I believe, but am doing a recovery scan on one atm, have several hours to go, so will let finish rather than start over) 200gb 7200rpm, 8mb cache. Formatted into 200gb (19+? after format NTFS 513kb cluster size , partions.

They are connected to a powered usb switching hub, connected to the following comps:

1) XP Home SP2, AMD 2000+ thunderbird, 512mb, Gigabyte GA-7VTXE mb

2) XP Home SP1 AMD 2800+ Barton, 1gb ram, Chaintech Zenith CT-7NJS mb

Settings on both comps for the externals are optimized for performance, and the stop device setting, which is religiously practiced b4 switching the hub and connected external hd's between comps.

HD 1) a different ext. when issue occurred hd totally corrupted, showed as 800gb etc..data successfully recovered have yet to zero and start fresh.

HD 2) in the above Kingwin enclosure... was functioning fine, but while connected to comp 2, after using several times, discovered it would not show in explorer. Did the safely remove thing prior to each of the following; power down, power up, unplug usb/replug, change usb ports on hub, ysb ports oon comp... the usb device was recognized but did not show in explorer.

Went into disk management showed as unallocated, same result in Partition Magic 8, tried the recover lost partition option w/o success.

In short the partion went missing along with 80+gb of data (running recovery, it appears all data is there, and 100% recoverable, upon abort scan partway in and checking found files and status.

I am at a loss as to why this is happening, it also occured on a WD 200gb Sata drive 200gb formatted NTFS single partion, when connected to the Chaintech MB's onboard Sata controled via promise fastrack in single drive array. Am using a pci sata controller card now..so far no issues, this drive is formatted fat 32 now and being used as the destination drive for recovery, the app requires a fat32 recovery destination drive.

Any advice as to what is going awry and how to remedy? It seems pretty mucked up not being able to depend on external hardrives because data goes missing when they corrupt or the the partion reverts to unallocated space as described above.

Is this a LBA issue? Is Maxtors Maxtor's Big Drive Enabler http://www.maxtor.com/portal/site/ma...&downloadID=11

or the Hotfix in the referenced MS bulletin the solution? The problems all occurred on the SP1 comp or Comp 2 above. This machine is not actively connected to the net, and is tweaked for gaming and for music and video use.
SP2 causes issues with the Morrowind Install I gathered from that forum. So do not wish to use it, and as the comp connects to the net for driver updates and desired MS updates, am not worried about the security flaws, and the security enhancements in SP2.

I have not checked if the Atapi.sys is 5.1.2600.1135 or above on Comp 2, data recovery scan in process (is 2600.2160 on the SP2 rig as I recall)

The SP1 comp in question sees the entire drive not just 137gb.
I have not had problems with the SP2 comp and the externals yet, but is a recent addition from spare parts, so may of not had enough time to mess with the external drives."


New Member
as much as try to understand all of that i still cant figure out what your initial problem was other then the drive isnt working like it should.

you need to state what the exact symptoms were first before anyone can make a guess, it seems like you have two harddrives and one enclosue? its really confusing man
Last edited: