DHCP not working on Belkin Router

D

danielgent

New Member
#1
Hi there,

Tried to setup a Belkin Wireless G plus Router. 12 months old but never been taken out the box. Connected the laptop to the router by ethernet cable. Vista didnt recognise the network and on the Vista internet status page the world was greyed out (even though the routers internet light was green). Ipconfig/ all showed the ethernet card wasn't being given a local IP address and instead was getting one of the those 168.x.x.x. ones.

Went through the wizard on the CD that came with the router and it asked me to reboot the laptop (saying it would restart after reboot). It never restarted after a reboot so I thought I'd do it manually (always much better doing it manual anyway!). I had to go through the manual to find the router had the IP address
192.168.2.1
So I gave the laptop the static IP address 192.168.2.50. It could now see the router (when connected by ethernet cable) and the vista internet connection page showed the internet as a green globe. Google and etc all worked fine. Then when I tried to set the wireless network up, same thing happened. Had to give the wifi card the address 192.168.2.50 for it to work. When setting the IP addresses back to automatic (e.g. assigned by DHCP) they didnt work. Couldn't ping the router as private IP addresses weren't being assigned

So the laptop is working fine at the moment but it can't be taken anywhere that has a router on the 192.168.1.0 subnet (is that the right terminology?).

I messed around in the setup pages of the router turning DHCP off (it was already on). rebooting, turning back on, etc a few times. Still no luck.

Is this router broken in some way or am I doing something wrong?

Much thanks for your help,
Dan Gent
 
D

danielgent

New Member
#3
I resetted the router to factory settings first thing. I was checking the settings the whole time by logging into the router at 192.168.2.1. Thats how I disabled an reenabled DHCP!
 

Associates