Creative AWE64 Hissing?



New Member
hi, i just installed my creative awe64 soundcard, and it hisses like heck! i dont know quite what's wrong with's also plugged into my cd rom, and cds play perfectly when i plug speakers or earphones into the jack at the front, but from the jack on the soundcard itself it hisses really badly, and chops during unreal, etc...the sound still comes through but the hissing is incessant. any ideas/suggestions/solutions?

thanks a lot!


New Member
A couple of things:
Check to see what port you have your speakers plugged into. If you have powered speakers, plug them into the line out port. If you have un-powered speakers plug them into the speaker port. The speaker port is amplified a few watts, and can cause hissing with most speakers when you plug them into this port. Also make sure you have all the drivers installed, and installed correctly. You may also want to check with the volume control panel and check all the settings (im assuming you are using either win 95 or 98).
Try adjusting the volume levels. Put most to the middle of the ranges, and adjust the main volume only from the speakers. Also with unreal, you will want to check what settings you are using, and possibly lower them. It is normal to get artifacts in the sound, plus playback issues due to the isa sound card interface. Pci cards dont have this problem, as they are not processor dependant. Try this stuff out and see if it helps. If not send me a mail.


New Member
Hi !
I had exactly the same problem with AWE64.
My previous creative 16 bit card was connected to CD-ROM with a cable which had big black connector on CD side and white small one - on card side and first time I used it to connect AWE64 also which resulted in the same problem like yours. But there is another jack on AWE64 board - black one, like on CD-ROM drive labeled AUX or something like this (the small white one is labeled "CD in" which is confusing). I found a cable which has big black connectors on both sides and used it to connect my AWE64 board to CD-ROM. This way everything is working for me.


New Member
if u are using a stereo reciever or unshielded amplified speakers try moving the amp away from your system. sometimes all that hardware causes interference that can cause hissing. also try using a shielded audio cable if u are using a reciever.
hope this helps.


Seeing Mole
Another thing worth checking out is that the MIC output should be muted. Also, if there isn't any particular things connected to the LINE IN port (such as MPEG cards or TV tuner cards) LINE IN should also be muted.