computer sees new SATA as primary

L

lmfbr

New Member
#1
I have a Dell 8100 Pentium 4, running XP Home. The boot disk is the factory (IBM) IDE drive. I added a second drive (a WD SATA) and a SATA card. All of this works fine. Today I installed a second WD SATA drive (the new 750 GB model) and plugged it into the open SATA connector on the card. When I turned the computer on, it immediately found the new WD drive and said "primary." At that point, it was dead. Obviously, the computer thinks the new drive should be the boot drive. I disconnected the drive and looked for some way to disable the boot path to the drive in the BIOS. I don't see anything to change. The boot sequence is floppy, optical disk, hard disk.

I also tried to start the computer with a boot CD in place (Ultimate Boot CD), but it still stopped when it identified the new drive and would not boot from the CD.

How can I get the computer to boot from the usual old drive, so that I can format and use the new one?
 
Steve R Jones

Steve R Jones

Administrator
#2
Check the jumper pins on the IDE...Guessing it might be set to CS. If so, change it to Master.
 
L

lmfbr

New Member
#3
Thank you. It is worth checking, but I am 99% sure the drive is set to master. It is the boot drive that arrived from Dell as the only HD. I doubt that they would have set it to slave. The computer has an optical drive on the primary, which should be set to slave.
 
Midknyte

Midknyte

Caffeine Fiend
#4
what kind of sata card is it? can you disable the bootrom/bios on the card?
 
L

lmfbr

New Member
#5
Arg! I have no idea what the card is. I put it in a rather long time ago. It is for the first generation of SATA drives and supports two. Since the new drive uses the latest SATA technology, it that may be a problem, but I hoped it would be backwards compatable. Maybe the porblem is not simply that the computer thinks it should boot from the new drive?
 
L

lmfbr

New Member
#7
Unfortunately, the drive was an OEM and arrived with no jumpers. I don't have a jumper, so all pins are open.

I gave up and removed the drive. I then installed the drive in a computer that has an Asus board and A64/3400 processor. The motherboard has connections for 4 SATA drives. This computer boots with the WD7500 connected, but the drive is not detected. Linux cannot see the drive. I booted with Partition Magic; the software found the old IDE drives, but not the WD7500. I then booted with the Ultimate Boot CD. From there I ran the latest WD drive software that was present. The WD software reported that no WD drives were present.

My present guess is that the drive is too new for my equipment. Any ideas for what to do now?
 
L

lmfbr

New Member
#9
I was wrong. I found a jumper. I also found the WD info for jumper settings. I will try to figure out which setting is required.
 
DanceMan

DanceMan

Procrastinating Member
#10
If the issue is needing a compatibility jumper for the WD Sata, you ought to be able to get one from a local shop or a friendly local hobbyist. The drive itself must be okay since your new Sata card sees it. The Asus might need the compatibility jumper to see it. I'm assuming the Asus is already using a Sata drive and Sata is enabled in its bios.
 
L

lmfbr

New Member
#11
If the issue is needing a compatibility jumper for the WD Sata, you ought to be able to get one from a local shop or a friendly local hobbyist. The drive itself must be okay since your new Sata card sees it. The Asus might need the compatibility jumper to see it. I'm assuming the Asus is already using a Sata drive and Sata is enabled in its bios.


I found some old jumpers. The really old ones were too small. The only other one I could find was on a discarded tape drive. It went on, but may not be tight enough to make contact. I may have to drive 15 miles and try to buy one.

My Asus manual shows 3 jumper settings: clear RAM, USB wake-up, and keyboard power. The board I have is A8V-XE. Those jumper settings don't seem to apply to the drives.

The Asus had two parallel IDE drives and two optical drives, no SATA drives, until today. I have the WD plugged into the first (red) SATA socket (primary).

I downloaded the WD software that has some drive tools on it. It boots from a floppy. When I boot with it, the software cannot find the new drive, but finds the two old drives.

Unfortunately, the WD explanation for the jumper settings doesn't make sense to me. I have written to WD's help center, but they have not given any human response for over a day. They sent links to instructions that have nothing to do with the problem.

I have also looked at the BIOS and don't see anything that looks like an obvious problem, but I am not knowledgable enough to figure this out in the first place.
 
Midknyte

Midknyte

Caffeine Fiend
#12
which system are you trying to install the drive on, the dell or the asus?

did you download the pdf on the link I provided? the jumper settings should be right on the top of the drive also.

OPT1: 150 MB/s data transfer speed enabled or disabled. Default
setting is disabled. To enable 150 MB/s data transfer speed, place a
jumper on pins5–6.
I've had to use the jumper trick at least a dozen times. In some cases, the board will flat our refuse to see the drive until you set it back down to 150M mode.
 
L

lmfbr

New Member
#13
Many thanks for all of the suggestions. After several additional tries yesterday, I tried again this morning, with the jumper on pins 5-6. When I ran WD Data Lifeguard Tools, it saw the new disk! After only a couple of minutes, it said the thing was ready to go as one partition (full size) NTFS. I managed to open the drive with Ubuntu and saw the formatted size at 698GB.

I still don't know if I used the correct jumper pair, but at least the drive seems to be alive and working.
 
Midknyte

Midknyte

Caffeine Fiend
#14
You must have done it right if you can see the drive now.

Some brands don't require the jumper. I know that WD does because we had a few customers try to return drives as "defective".
 
equinoxe3d

equinoxe3d

New Member
#15
Midknyte said:
You must have done it right if you can see the drive now.

Some brands don't require the jumper. I know that WD does because we had a few customers try to return drives as "defective".
Could it depend on the SATA controller too? I have an un-jumpered 5000AAKS and it auto-negotiates perfectly with my insanely old SATA1 board.
 
Midknyte

Midknyte

Caffeine Fiend
#16
Yup. It could be the way the manufacturer implemented the chipset/controller. Intel, Nvidia, VIA, SIS, etc all do things a little different.

The point is if your SATAII drive isn't seen, try the compatibility jumper first.
 
L

lmfbr

New Member
#17
A new SATA controller would probably work. The two SATA cards I have are PCI for the first generation drives. I ended up having difficulties accessing the drive from Ubuntu (I got a "you don't have permission to write to this drive" message). I tried everything I could think of, then gave up and moved the drive to my only remaining computer (A64/4000 Alienware). It would not work there, either from the mobo or the card, until I put the jumper on 5-6. I tried 1-2 and 3-4 but they didn't work. As of now, the drive is working fine. I am using it to backup large files and thought it would be a little better to have it in one of my other machines, doing the backup through the router.