CD Rom won't work



New Member
I have a 586, 32mb ram, 24X mx Creative CD Rom Drive. My problem is that I have been trying to install Win98 and I can hear it madly spinning in the drive but then I get a "drive not ready" message and that's as far as I can get.
All my other CD's work perfectly so I would think it isn't the drive, but then I have taken the CD to my sister's place and it worked immediately in her drive... so I I'm guessing it's not the CD either.
Can anyone give any ideas what the problem could possibly be and if there is something I can try to get it up and running.
Thank you.... and a Happy New Year to you all.


New Member
My guess is that its your drive. I have that exact CDROM, the Creative 24Xmx, and i can tell you, i hate this damn thing. Sometimes it works, sometimes it doesnt. Its insanely loud, and sometimes has troubles reading cds at all. Im definitely guessing its the CDROM especially since the CD worked fine at your sisters. I really dont know what to tell you though, if i knew how to fix it, it wouldnt be making this noise right now. (sometimes a swift smack to the side of the thing helps, but i dont recommend that) I guess the only real way out is a new CDROM.


New Member
Here's something that might help determine if it's the CD ROM Drive - while you have the suspected win98 cd in the drive and it is spining and trying to load, open and close the cd tray. I have found that some times this helps align the head with the track on the disk in a bad drive. Give it a shot and let me know if it works for you.
Good luck,


New Member
I have a Plextor 14X-32X with a similar problem. It wouldn't read some CDs. Others, like even Bookshelf 99, it would spin up madly, as you said; then I would get a blue screen with a message "not reading drive X:; make sure Cd is is drive, or maybe it needs cleaning." Plextor has software that allows you to control speed and spin-down time of drive (part of the problem is they stop spinning after a couple minutes so they won't get hot). Anyway, I called Plextor and they sent me a firmware upgrade (a chip) that seemed to cure the problem. I guess these high-tech drives represent real progress!