CD-ROM tray won't open. Need HELP !

L

lennieboi

New Member
#1
I just assembled a new box, but CD-ROM tray will not open. CD-ROM is detected at the initial boot up, the light comes on, and it sounds like it spins - but the tray will not open after I press 'eject' button.
I've tried several different IDE cables, tried switching from secondary to primary and back, I bought a new drive - but with no success. I've tried to elliminate IDE/ATAPI incompatibility and started the machine without IDE cable connected, still I can't open the tray. I know for sure that CD-ROM drives are good(new and old), since they work fine when I plug'em into a different machines. I can probably open it with a paper clip, but that only be a temporary solution to a problem. The only remaining thing is Power Supply, but again the light comes on and it sounds like the drive is spinnning.
I am completely lost at this point, any help would be greatly appreciated.
Thanks, Len
 
M

mjdart

New Member
#2
Does it respond to windows telling it to open. Right click on proper drive and eject

------------------
Intel [email protected]
512MB PC800 RDRAM
80GB & 20GB ATA/100
Nvidia GeForce 3 Ti 200
LiteOn 16X DVD ROM
LiteOn 10x/16x/40x CD-RW
SoundBlaster Live 5.1
24" SONY GDM-W900
Windows XP Home
 
Z

zodiac_hl

senior citizen
#5
the cd rom needs a driver for the door to open,from windows or a boot disk.


------------------
MSI k7t266 pro2
AMD xp [email protected]
geforce 3
creative audigy platinum
 
R

Rave

New Member
#6
Alrighty, first thing.... A CD Rom does not require a driver to open the cd rom, this is a hardware function, not a software function.

Secondly if the change of power supply plug does not work, then try this next step:

A while ago a got a Panasonic cdrom drive and it would not open, this was because the actual tray was jammed by the flap on the front of the tray.

On the front of the cd rom, you will see a small hole, probably near the eject button. Get a needle or a paperclip and slide into this hole. This will release the door and you will be able to manually open the tray yourself.

Once you have it open, check that the door slides open and shut without touching any edges etc. The common cause is the flap on the front of the tray is slightly loose. Make sure this is clipped into place correctly.

The problem with mine is that it was not properly closed, so when the power would come on it would be continually trying to close and would not open. After I did the above, it is now good as gold


Do this with the power turned off.

Cheers.

------------------
"Oh I'm sorry, did I break your concentration"?