can't enable Aureal 3d sound in Diablo 2

U

unger

New Member
#1
I have an MX300 card and am using the latest Aureal reference drivers (2048) on Windows 98 and latest a3ddrivers.exe (3.12). Have DirectX7.0A as well. Well I cannot enable 3d sound. When I click it under options to turn it ON from OFF it takes a second then doesn't toggle to ON. It stays OFF after clicking like its not possible to enable it. Has anyone gotten the Aureal drivers to work with Diablo. Dumb thing is I tried some Demos like Deep Space 9 and Star Trek Armada and they have no problem using the Aureal 2.0 3d sound. Didn't even have to enable it, it was on by default. Only thing I can think of is that I installed the game before installing the sound card and drivers. But I did run the Test program again.
 
U

unger

New Member
#3
Thanks I looked at that before but that is a different 3d sound option. EAX instead of Aureal 2.0 so its a different problem.
 
X

XxMxAxDxX Pyro

New Member
#4
well diablo2 is supposed to support a3d, eax and directsound3d.

but unfortunately it seems like a3d was never properly implemented in the game. it simply doesnt work. eax should work with the newest drivers (since they support eax) but it seems like eax2 is used in diablo2 wich is not compatible.

the problem is that diablo2 looks for 3dsound apis. it detects eax and tries to enable it but notices that it is only eax1 not eax2 so it doesnt enable 3dsound at all...
well u should be able to use directsound3d under diablo2 (which doesnt make a big difference in the game) by just disabling the whole eax-engine in the drivers...
disable the reverb engine in the vortex control panel under a3d settings to do so (the vortex control panel should be aviable in ur systray)

it did work for me this way.

c ya

MxPyRo
 

Associates