Cannot delete bootex.log

F

freshmania

New Member
#1
Hi guys,

Everytime I do chkdsk c: /f and restart my computer to do it, it would freeze after it says '..your computer is restarting...'

So I have to hit the reset button and so I can go back to windows. After this, I have a file called C:\bootex.log that I cannot delete and even chkdsk reports it as a corrupt file.

What I know is chkdsk creates bootex.log during its process and it should copy it to event log and delete the file. I guess it always fails when it tries to do the last part. Any ideas?

Im running WinXP pro with the latest patches. Actually, I've had this problem since I installed winxp.

Thanks.
 
Berserker

Berserker

New Member
#2
Copied from other forums. Hope it helps.

No. Bootex.log is a file created by chkdsk.exe when it is run; its results are rolled into the main log after the system finished booting. If chkdsk.exe is interrupted, bootex.log can become corrupted. When chkdsk.exe runs again, it tries to write to bootex.log, which is, unfortunately, now corrupt. It doesn't know this until after the check; so even though it was deleted by chkdsk.exe, it was written to in the mean time and is therefore still corrupt. The fix is to run under the Recovery console by either booting from the Windows XP CD or running \i386\winnt32.exe on the Windows XP CD with the argument /cmdcons. When in the console, run chkdsk.exe /p to fix the file. Then type del c:\bootex.log to remove the offending file. Reboot, and all is taken care of.
 
N

Neilrahc

New Member
#3
resolved: bootex.log

1st, thanks for the insights into the creation of bootex.log and interaction with chkdsk. Hard to find much on this.

I was able to resolve the bootex.log corruption by running chkdsk G: /r

It went through all the files, indexes, permissions checks normally. In the process it deleted bootex.log. It did give an error ("unspecified" I think) on the free space check, but no big deal.

Afterward I ran chkdsk G: /f as an added sanity check. It all ran well and no more errors messages. Backups worked and I can access all the files.:)

(Since this was the G: drive I was able to run from the command line without having to go to Recovery Console.)
 

Associates