Intellimouse Explorer 3 problem?
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 4 of 4

Thread: Intellimouse Explorer 3 problem?

  1. #1
    Join Date
    May 2000
    Location
    Sunderland, UK
    Posts
    194

    Intellimouse Explorer 3 problem?

    I just bought a MS IntelliMouse Explorer 3 today and i was wondering something.

    When every i lift the mouse from the desk, the mouse cursor jumps to the top right hand corner of the screen. I was wondering if this was supposed to happen or whether my mouse is faulty


  2. #2
    Join Date
    Mar 2000
    Posts
    27,273
    Does not sound right.
    "I know nothing."
    Cheers.

  3. #3
    Join Date
    Dec 2001
    Location
    IL
    Posts
    23
    See what happens when you use the mouse over a different surface. The surface you're using might be confusing your mouse when you lift it up. I've had a similar thing happen, but only 2 or 3 times in the past month, usually when something (like a dog hair) gets between the optics and the desk.
    "The Overclocker's Nightmare"
    P4 1.9G
    Intel 850MV
    512MB PC800 RIMM
    VisionTek GF3 Ti200
    IBM 60GB 60GXP
    SB Audigy
    Klipsch Promedia 4.1

  4. #4
    Join Date
    May 2000
    Location
    Sunderland, UK
    Posts
    194
    I have now tried the mouse on 2 different pc's and it does the same on both, i am going to take the mouse back me thinks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •