Fitting CD-ROM to 486 - problems
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 9 of 9

Thread: Fitting CD-ROM to 486 - problems

  1. #1
    Join Date
    Sep 1999
    Location
    UK
    Posts
    6

    Fitting CD-ROM to 486 - problems

    Hi there.

    Got an old 486dx machine, running Win 3.11 at the moment. Wanna fit an internal CD drive, bought Mitsumi 40x model and IDE controller card.......

    Problem: fit both. Power light shows on CD drive. Installed DOS drivers. System says on boot "no CD-ROM unit found. Installation abort" I've checked jumper settings on everything, turned the IDE leads all ways round - no joy.

    Anyone know what I'm doing wrong?
    "I'm trying, honest!"

  2. #2
    Join Date
    Sep 1999
    Posts
    22
    What else is in your system? Are you using both the master and the slave on the other IDE controller? Reply back with what other IDE devices you have.
    -lex

  3. #3
    Join Date
    May 1999
    Posts
    190

    When you boot up does your system hang at any point? If I recall correctly; MSCDEX (sp?) should be in your Config.sys and the actual cdrom drivers in your autoexec.bat. Does your mscdex find your cdrom?

    the Mscdex is sometimes included with dos and/or windows, or in their respective directories. If you have the install disks, use the one on them.

    Best bet is to REM or delete the cdrom lines added in your config.sys and autoexec.bat and try reinstalling. I've found that a failed install sometimes confuses the simple install scripts.

  4. #4
    Join Date
    Sep 1999
    Location
    UK
    Posts
    6
    Well, I have only a 325 Mb Seagate hard drive on the original IDE controller (the original exp. card with that motherboard, nothing else. The CD is still not found when connected as slave to the original drive.

    I was advised to buy an up-to-date controller card, after trying everything else I could, but no joy with that either. Apart from the fact that the old hard drive will not work with the new card.

    System doesn't hang at all - I can do anything else in DOS and Win 3.11 but the CD drive is never found. Drivers load OK, then the "no drive found" message appears.

    I actually have 3 of these bloody things, ex-office, supposed to be on their way to some of our unemployed trainees...... funny thing is, an identical machine is running a 24x CD drive with no problem, and no detectable change in setup. Wierd.

    Make is an Evesham Vale Premier 486SX50, if that helps. (UK company)
    "I'm trying, honest!"

  5. #5
    Join Date
    Sep 1999
    Location
    Sarasota, FL
    Posts
    162
    Far more important, actually, is the harddrive model. It may be set for single-drive operation and not be looking for a slave drive. In addition, since your drive doesn't work with the new controller, you might have some sort of non-standard setup.

    Try making a boot floppy with your CD-ROM drivers on it. Your startup files should have the following (minimum):

    config.sys:
    device=mtmcdai.sys /d:cd1

    autoexec.bat:
    mscdex.exe /d:cd1

    Copy those files (mtmcdai.sys and mscdex.exe) to the floppy. Then disconnect the harddrive, set the CD-ROM as master and boot from the floppy. You should be able to access the CD-ROM. If that works, you can probably set your harddrive to slave and all will be well.

    If you can't find the jumper settings for your harddrive, email me the model number and I'll find them for you. The current jumper settings of the drive might be helpful as well to figure out if something "odd" is being done. Also the controller model if you can find that.

    Good luck!

    ------------------
    -=DrFoo {Sysop} Third Wave BBS (941) 355-7136=-
    http://dsl150-37.cftnet.com
    -=DrFoo {Sysop} Third Wave BBS (941) 355-7136=-
    http://163.125.153.98

  6. #6
    Join Date
    Sep 1999
    Location
    UK
    Posts
    6
    Finally got this damn box home, where I can play properly. And get the settings and messages first-hand.

    Well, that didn't work either. Made boot floppy: copied MSCDEX.EXE to it, fine. MTMCDAI.SYS does not exist on my system, so I subbed in and copied the driver specified by the CD manufacturer.

    The CD drive is made by Pine Technologies, and the driver specified is CDTECH.SYS.

    The actual line in my CONFIG.SYS file reads:

    DEVICE=C:\CDROM\CDTECH.SYS /D:SMCDOO1 /UDMA2 /V

    .... I get the feeling that /UDMA2 bit is important. Right???

    The disc booted fine, but I got the standard "no drive found", plus a "no valid device drivers found" as well. I had to leave the hard drive connected, but I swapped the CD drive to master & the HD to slave. If I disconnect the HD, floppy boot hangs at "WAIT....."

    I do have more system details, though.

    AMI BIOS 40-900-006259-00101111-060692-symp-h

    Main processor is an 80486dx2

    The drive is actually a Seagate Medalist ST32531A - I have the jumper settings, nothing funny there. Currently set to "master or standalone"

    The original controller card is a Promise Technologies board, made in 1993.

    I've run through the boot-up messages, and looked at the cache configuration.

    Cache Setup Utility V4.1 Promise Technology (copyright etc....)
    Primary controller Firmware V4.1 BIOS V4.1
    Drive Cache DC4030VL-2 512k cache memory


    So, I went into the Cache setup.
    SETUP CONFIG:

    Cache mode: Fast (cache enabled/Write Through)
    Disk I/O Handler: Turbo (DC4030VL-2 BIOS remapped)
    Interrupt Selection: Dual Controller (Primary)
    Bus Speed: 50Mhz or faster
    BIOS address: D8000H
    Drive parameters: Drive 0 4956 cylinders, 16 heads, 63 sectors


    Boot up goes fine until:

    CD-ROM Device Driver for IDE (4 channels)
    Driver Version: 3.2
    Device Name: MSCD001
    Chipset type: none
    No drives found, aborting installation.


    CD-ROM power light flicks on and off, ok.

    Hard drive light has taken to staying on, even when I boot from floppy.

    Note, the Promise is the original controller card. The system documentation doesn't mention CD drives at all, but does say that the Promise supports 4 IDE drives.

    Any more ideas? I've got 3 desperate people on my back ....

    "I'm trying, honest!"

  7. #7
    Join Date
    Jul 1999
    Location
    El Segundo, CA USA
    Posts
    40
    I never was able to add a CD-ROM to my 486 - at least, not without disconnecting one of my two HDDs. (My 486/50 ran like a 386/33 without the swap file on a 2nd HDD.) My problem was partly the age of one of my HDDs. Both were made by Conner, but Seagate put its name on my 550MB ST35104. This HDD worked find as a master to the CD-ROM slave but performance was so unsatisfactory that I disconnected the CD-ROM and reconnected the 2nd HDD as soon as I'd loaded whatever (virus software). My older Conner HDD was of type MFM and wouldn't work with the CD-ROM.

    In order to run off a controller card, I should've disconnected the onboard IDE controller. The controller card supported more IDE channels than did my machine. Because I was confused about AMI's advice (mind was an AMI board, not just the BIOS) I didn't disconnect the onboard controller and blew out all of my I/O (including my onboard FDD controller which never recovered).

    Rebuilt up to a Pentium II 400MHz ATX, but the myth about backwards compatibility with all older devices didn't apply to my MFM HDD. Settled on a straight Pentium 233 for a time and which did recognize and automatically configured all devices on both IDE channels (this newer board supported 2 IDE channels for 4 devices whereas my 486 supported only a single channel for 2 devices.)

    Have you tried getting online support for your motherboard manufacturer, or don't they have a web page? AMI answers only questions on motherboards made by AMI and not Intel. Seagate supports questions about all older HDDs including those manufactured by Conner. You should be able to get online support from Seagate. There's a way you can read the URL from their web page and construct a tech support email address, but I've forgotten whether it was techmail@seagate.com or something else. They didn't advertise an email address, but I was able to sneak up on them. Hope you can too and that things work out okay.
    Be happy while you're living, for you're a long time dead.
    - Scottish Proverb

  8. #8
    Join Date
    Apr 2000
    Location
    Minneapolis, MN, USA
    Posts
    4
    Hi,

    First of all, I am really novice in this field. I hit upon this website when I was searching on cdrom fitting problems for 486.

    I was trying to fit a 48X cdrom to a Compaq 486dx / 33 mhz running Win 3.1.

    I set the jumper settings of the cdrom to slave. I could run the installation program. Now when I switch on it gives the following
    message after the memory check (even if both the HDD and CDROM are connected to the IDE cable, or only the HDD is connected) :

    Atapi ide cd-romn device driver.
    etc etc
    Driver version : 2.9
    Device name : MSCD001

    CD-ROM Driver not ready
    Abort/Retry ?

    On aborting it starts Win 3.1.

    Question :

    1. Is a jumper setting required for the HDD to make it specifically the master? (I dont have any manual for the HDD!)

    HDD Details :
    Conner, CP 30121E
    Compaq model no : 131390-001
    Type : 50

    2. Is there anything else I am missing?

    3. I am not sure about what an IDE controller card is and where is it inside the computer?

    Thanks.
    -Suvo

  9. #9
    Join Date
    Oct 2001
    Location
    Orange, NSW, Australia
    Posts
    1
    I'm having the same probs with a Pine Technologies PT-944A cdrom on a compaq 486, I don't have the entire system specs but If 1 of u fella's can give me a hand plz replie I'll post the rest of the spec L8r

    Yours Wishing and hoping

    NeophobiA

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •