I Want My D:\ to D:\ Not F:\
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 10 of 10

Thread: I Want My D:\ to D:\ Not F:\

  1. #1
    Join Date
    Mar 1999
    Location
    Pine Island,NY
    Posts
    26

    I Want My D:\ to D:\ Not F:\

    Ok lets say I know enough about computers, or at least I thought so. Here's my problem: My CD-Rom was as 97% of most pc users the D:\ drive. After installing a second hdd which are partitioned now my D:\ is F:\ and it will not detect any CD's which where installed. What I want is the cd-rom back to d:\. Help me please. Any suggestions? Thanks.

    ------------------
    Don't Drink & Surf...

    [This message has been edited by WhatThe (edited 03-11-99).]
    Don't Drink & Surf...

  2. #2
    Join Date
    Mar 1999
    Location
    Norway,Oslo,Skjetten
    Posts
    22
    First of all, i hardly get why yo want your
    CDD back to D: if your second harddrive should be there, but anyway if you do:

    Try System/CD-ROM/Properties/Settings set
    Start drive letter and End drive letter to D:
    Good Luck. 8)
    What's that?

  3. #3
    Join Date
    Nov 1998
    Location
    richmond, VA USA
    Posts
    95
    WhatThe,
    Here's what happened...You previously had
    C: for the hard drive - D: for the cd-Rom. When you installed your hard drive and partitioned it, the OS now goes: 1st drive is
    C: 2nd drive/1st partition is D: 2nd drive/
    2nd partition is E: CD-Rom is now F: -- I assume you have the 2 harddrives setup up as slave and master and the cd rom on its own ide channel? I ran into the same problem you had and I even tried to force CD-Rom to D: (in device manager for CD-Rom in WINDOZE 95) Didn't work, the OS still assigns drives the way it wants too. You might want to try making the CD-Rom a slave to the 1st hard drive. But 1) i don't know if that will guarantee the cd-rom going to d: and 2)that will probably slow the performance of the 1st hard drive. Hopefully my long post was helpful...

  4. #4
    Join Date
    Nov 1998
    Location
    richmond, VA USA
    Posts
    95
    Forgot to note in my previous post...As far as none of your installed programs now working - check all the shortcuts for those programs. If you have any shortcuts on the desktop, right click on them, then select the
    Shortcut tab. Change all D: to F: That should hopefully fix the vast majority of problems.

    [This message has been edited by Big Daddy (edited 03-11-99).]

  5. #5
    Join Date
    Mar 1999
    Location
    Pine Island,NY
    Posts
    26
    Hey Big Daddy and Amn Thanks for the info. Big Daddy that's a good idea with the shortcuts. Thanks again guys.

    ------------------
    Don't Drink & Surf...
    Don't Drink & Surf...

  6. #6
    Join Date
    Feb 1999
    Location
    RI, USA
    Posts
    249
    What you want to do is change your CD-ROM drive to "M". This way anything else you add in the future you will not have to change your CD-ROM drive letter again.
    Dell C640 Laptop (wireless) or my trusty old desktop system:
    Abit BH-6 PIII 800e (100mhz) 192 Meg RAM PC100 Gainward GeForce2 Ti/450 SB Live Value Sony 8X/4X/32X Viewsonic 19"
    "Krell Power"

  7. #7
    Join Date
    Feb 1999
    Location
    RI, USA
    Posts
    249
    What you want to do is change your CD-ROM drive to "M". This way anything else you add in the future you will not have to change your CD-ROM drive letter again.

    ------------------
    SlipKid
    Dell C640 Laptop (wireless) or my trusty old desktop system:
    Abit BH-6 PIII 800e (100mhz) 192 Meg RAM PC100 Gainward GeForce2 Ti/450 SB Live Value Sony 8X/4X/32X Viewsonic 19"
    "Krell Power"

  8. #8
    Join Date
    Mar 1999
    Location
    Durham, NC, USA
    Posts
    191
    Also check to see if any of the games that don't work now installed any .ini files - they may need to be edited to search for the correct drive letter (e.g. War Craft II)
    Skywalker is here and the Force is with him!

  9. #9
    Join Date
    Mar 1999
    Location
    Pine Island,NY
    Posts
    26
    G-Master, are the .ini and .inf files the samething?

    Thanks

    ------------------
    Don't Drink & Surf...
    Don't Drink & Surf...

  10. #10
    Join Date
    Apr 1999
    Posts
    10
    As has already been mentioned, it is DOS that has assigned the drive letters this way. It assigns all fixed media drives before removeable media drives. One common way to get round this is to get Windows to assign the CD a letter that is not likely to be used by DOS - conventionally this is R. This feature only applies to a Windows machine of course (95, 98 or NT). Booting DOS will still show the CD as E, F or whatever.
    The trick is, of course, to make the change to R when the system is originally configured, BEFORE installing software.

    The best you can do now is get hold of one of the several application moving utilities available, change your drive letter to R then "move" all your apps to the new drive. All this actually does is scan ini files and the registry for instances of the old drive letter and substitute the new one. The apps themselves are not physically moved at all. Remember this does NOT cover apps running under DOS when the machine has been booted into DOS.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •