Recurring problems with Mitsumi CD-ROM
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 2 of 2

Thread: Recurring problems with Mitsumi CD-ROM

  1. #1
    Join Date
    Dec 1998
    Location
    Chicago, IL
    Posts
    186

    Recurring problems with Mitsumi CD-ROM

    I'm in the process of building a new computer but my old computer is having some major CD-ROM problems. The system is shy of 3 years old. I had my first Mitsumi 6X CD-ROM replaced about a year after I bought the system. It was replaced under warrenty because it was defective. It would take a LONG time (nearly a minute) to access the drive and would hum and rattle VERY loud then stop dead and repeat. They replaced it with a newer 8X Mitsumi CD-ROM. Hear I am a year and a half later and the problems are similar but MUCH worse. Same symptoms as above plus it many times will never access the drive. I may have the CD drive disappear altogether or upon access to the drive it will reboot my system. Is this typical of Mitsumi drives? Seems suspicious that it happened twice about 1 year after installation. They both worked fine when they were first installed. Are their drives 1 year disposable drives?

    Thanks for any help!

  2. #2
    Join Date
    Dec 1998
    Posts
    21
    I have seen those symptoms several times not necessecarily with the same manufacturer. Anyhow to the point, each time I ended up with a new one. If it is still in warranty have them replace it else it is going to cost you $45 IDE version of course. SCSI a bit more.
    I guess at $45 it could be considered disposable.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •