Drivers for Geforce 2mx & older Athlon ??
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 7 of 7

Thread: Drivers for Geforce 2mx & older Athlon ??

  1. #1
    Join Date
    May 2000
    Location
    Australia
    Posts
    94

    Drivers for Geforce 2mx & older Athlon ??

    I bought an ASUS Geforce 2 MX 1 week ago. It's very stable i'm glad to say. I got Athlon 700 with an Irongate Chipset, running Win ME.
    I was recomended to use Detonators 6.50, so i installed them tonight and realised that the card performed worse, than what it did with my previous 5.32 detonators, which i originally used with my old TNT2. i used GL Excess for benchmarking and: it scored 2190 with 5.32, and only 2103 with 6.50. I can't say much for D3D, but i do know that games like Clive Barker's Undying get FPS of 19 in large open areas
    i'm kinda lost now.. should i go back to 5.32 dets, or is there something else i can do?? i want the best performance possible, preferably without having to o/c anything.

  2. #2
    Join Date
    May 2000
    Location
    Australia
    Posts
    94
    Just realised another thing: it was running at AGP 1x despite the fact that i used that regestry patch. So i pushed it to 2x using Powerstrip. It's ROCK-STABLE running D3D games, but exact opposite for OpenGL, can't even get 2 frames out of it b4 it freezes.
    hmmm...
    Any suggestions??

  3. #3
    Join Date
    Oct 1999
    Location
    Zagreb,Croatia
    Posts
    1,824
    7.58 but I don`t know where they can be downloaded. Newer detonators bring support for GF3 and newer T&L instructions and to be honest I don`t know how can that be helpfull to "old" GF2 chip.

    BTW I never had any problems with MX @ AGP 2x on Irongate MBs, rev. 5 (chipset that supports SuperBypass).

    With AGP 2X enabled average increase in gaming was oround 10%.

    I would stick with 6.50 drivers cous they give best compatibility and for me that is moust important part.

  4. #4
    Join Date
    Mar 2000
    Location
    mojave ca. usa
    Posts
    302
    http://www.3dchipset.com/drivers/nvidia/nvidia.html
    try that link thats where i dl my drivers... gl

    ------------------
    5inch penis @ 9inches
    superheated
    9inch penis @ 5inches
    supercooled

  5. #5
    Join Date
    May 2000
    Location
    Australia
    Posts
    94
    Just installed 7.58s... no diference for D3D, but OpenGL DOESN'T RUN AT ALL!!!

  6. #6
    Join Date
    Nov 1999
    Location
    Suffolk, UK
    Posts
    3,849
    I have an 'Classic' Athlon 500@700MHz on an AMD-750 chipset motherboard and a GF2MX@175/195 and I have found I get the best performance from the 7.58s - I don't get any problems in games either (besides Star Trek: Armada, but that game was programmed by monkeys ).

    Might sound obvious, but have you got the lastest patches for your games?

    ------------------
    Speed is everything - Warp factor 9, Mr. Sulu!

  7. #7
    Join Date
    Dec 1999
    Location
    whitby/ cobourg, ont, canada
    Posts
    1,263
    i'm not sure but maybe somthing happened to your opengl32.dll file in c:windows/system. try and get some one with the same os as you to send you there file and then you replace it
    duron 800@900 - asus a7v - 640mb pc133 - radeon 8500le 128mb - sb live - 16x dvd-rom - 48x24x48 burner

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •