Video Card Hell!!!
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 4 of 4

Thread: Video Card Hell!!!

Hybrid View

  1. #1
    Join Date
    Feb 2001
    Location
    Mystic, CT, 06355
    Posts
    17

    Video Card Hell!!!

    I just purchased a new Creative Labs Savage 4 AGP with 32 megs of ram. It has great 3d gaming in mechwarrior, flight sim, nothing to extreme. But one small problem, the main menu on both games comes up screwy, Mechwarrior it is off half of the screen, and in Flight Sim it is garbled like you have to high a res for my moniter. But both of these problems go away once you get into the game, whats going on? Also in flight sim if I hit Alt+Enter it runs fine in a window. I have downloaded the newest drivers and patches but nothing. HELP.
    Thanks,
    Chris Svencer
    Svence

  2. #2
    Join Date
    Oct 2000
    Location
    Sri Lanka
    Posts
    678
    I don’t know about those particular games, but normally in most of the games (not all) the main menus appear in 640x480 (low bit depth). That could be your problem. Just set the desktop resolution (in windows) to 640x480 and adjust the monitor settings to fit the screen & so on (if you have a digital monitor then the monitor will remember the settings for 640x480 / if you have a monitor with knobs to adjust the size , position….. then set the screen using the software which came with the VGA card) . After that switch to your normal resolution. Afterwards when ever you run the games it should look okey.


    I hope this helps

    1. AMD AXP 2600+ @ 2.34Ghz (167x14) Cooled with CoolerMaster Aero7+ / Asus A7V8X-X (KT400) / 1GB 333MHz RAM / Maxtor 120Gb DMAX Plus 9 / GeCube Radeon 9600Pro / PixelView PlayTV Pro / Acer 21” Monitor / SB Live! / NEC ND-2500A 8x DVD±RW / Sony CRX-320EE Combo Drive

    2. AMD AXP 1600+ (Stock cooler) / MSI K7T Turbo2 / 512Mb 133MHz RAM / Maxtor 80Gb DMAX Plus 9 / Gigabyte Radeon 9200 / Philips 17” Monitor / Sony CRX 160 CDRW / Asus E616 16x DVD

    3. IBM 300PL PIII

  3. #3
    Join Date
    Dec 1998
    Location
    Knoxville, TN
    Posts
    699
    Question: With prices on the MX line of cards so cheap, why on earth would you get a board with the Savage chipset?!?!?! You better had gotten a hell of a deal on it to justify it...say $15 US.
    Intel i5-2500K 3.3GHz
    Asus P8Z68-V Pro/Gen3
    8GB G.Skill RipJaws DDR3 1600
    EVGA GTX 570 HD 2560MB
    Crucial M4 128GB SSD
    Corsair HX 620W
    Win7 Pro 64-bit SP1

  4. #4
    Join Date
    Jul 2000
    Posts
    18
    go to http://sdnews.net and get the latest drivers. You'll also need to download and install a new bios in your card. Creative should have one.

    [This message has been edited by logic7 (edited 04-11-2001).]

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •