Viper 2 driver probs with win 2k
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 5 of 5

Thread: Viper 2 driver probs with win 2k

  1. #1
    Join Date
    Feb 2000
    Location
    Swindon, England
    Posts
    737

    Viper 2 driver probs with win 2k

    nice to see u are a mod now Blade Congrats.
    Ok this is my problem, when i installed the relased drivers for win2k for the viper 2, it does a memory dump and reboots just before entering the shell and i am pissed at s3 for releasing drivers that 1, are not certified and 2, dont work. can anyone help me? anyone else out there with this problem or a solution? please!

    thanx.

    ------------------
    If its not broke, don't fix it!
    Athlon XP1600+ @2000+ Alpha PAL 8085 MSI K7T266 R126 512mb Crucial CAS 2.5 DDR
    Gainward Geforce 2 Pro /450 GS 2 40Gb 60GXP's In RAID 0 Black Dell P791 SB Live PLatinum 5.1 Black GW 802

  2. #2
    Join Date
    Oct 2000
    Location
    Minneapolis, MN, USA
    Posts
    2,689
    Go to www.savagenews.com and get some of the latest tweaked drivers.

    ------------------
    Gimme my TriLevel Cache
    Modded Matrox Parhelia 128mb Retail
    AGUIA Y TBRED 1700+@2ghz
    Epox 8K3A+

  3. #3
    Join Date
    Dec 1999
    Location
    UK
    Posts
    1,473
    Hah,
    welcome to the wonderful world of S3! I have a Viper II and it barely works in Windows '95, let alone NT or 2000. I have heard that there are some tweaked drivers around, or you could try the SDK driver sets at www.s3graphics.com, but to be honest even if you can get into Win 2000, you're going to have massive hassle getting any games to run without either:
    1) Massive texture corruption and image distortion.
    2) The PC crashing at fairly regular intervals........
    Don't get me wrong, I like the Viper, but I will freely admit that it has the worst drivers I have ever seen, even beating out the Savage4 card I have.
    Good luck! (you're gonna NEED it)
    Fallguy

  4. #4
    Join Date
    Oct 2000
    Location
    Minneapolis, MN, USA
    Posts
    2,689
    A reason you may have trouble with the ViperII under win95 is the terrible AGP implementation under 95. Try 98SE and see if it improves.

    ------------------
    Gimme my TriLevel Cache
    Modded Matrox Parhelia 128mb Retail
    AGUIA Y TBRED 1700+@2ghz
    Epox 8K3A+

  5. #5
    Join Date
    Dec 1999
    Location
    UK
    Posts
    1,473
    No,
    the reason I have terrible trouble with the Viper II is because it has rubbish drivers - it doesn't matter what OS you use (and yes I have tried '98, it still has EXACTLY the same problems). Worse, S3 is no longer developing the drivers for the Savage2000, so if it don't work now, it never will work!
    Fallguy

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •