how do i diagnose a broken video card EVGA nVidia e-GeForce 9500GT 512MB DDR2 DVI + V
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 3 of 3

Thread: how do i diagnose a broken video card EVGA nVidia e-GeForce 9500GT 512MB DDR2 DVI + V

  1. #1
    Join Date
    Jun 2013
    Posts
    10

    how do i diagnose a broken video card EVGA nVidia e-GeForce 9500GT 512MB DDR2 DVI + V

    I have an old generic computer with a EVGA nVidia e-GeForce 9500GT 512MB DDR2 DVI + VGA PCI x16 Video Card 9500 GT

    I believe it has failed as the computer seems okay but no display.... it may be the motherboard..... is there a cheap way to diagnose the video card? i am pretty broke and if i need to spend much i would end up buying a new computer.... i cant tell what is wrong.....

    please help me the fan still runs on the video card but i really believe that's what failed....

    also there is no beep from the "internal beep maker" sorry for the lack of terminology ... like when it boots

    Any positive thoughts, i would rather not lose this build


    Thanks

  2. #2
    Join Date
    Dec 1999
    Location
    Augusta, Georgia, USA
    Posts
    3,943
    Quote Originally Posted by MrNice View Post
    I have an old generic computer with a EVGA nVidia e-GeForce 9500GT 512MB DDR2 DVI + VGA PCI x16 Video Card 9500 GT

    I believe it has failed as the computer seems okay but no display.... it may be the motherboard..... is there a cheap way to diagnose the video card? i am pretty broke and if i need to spend much i would end up buying a new computer.... i cant tell what is wrong.....

    please help me the fan still runs on the video card but i really believe that's what failed....

    also there is no beep from the "internal beep maker" sorry for the lack of terminology ... like when it boots

    Any positive thoughts, i would rather not lose this build


    Thanks
    Do you own or have access to another card that you can put in and try? If that brought your video up, it would isolate the issue to the card and rule out the motherboard.

    Your not getting a beep during the POST when you start up the machine would be consistent with a bad card (among, unfortunately, some other things).

  3. #3
    Join Date
    Jun 2000
    Location
    Vancouver, B.C., Canada
    Posts
    8,101
    If you can get hold of an old video card from an obsolete computer, one being trashed or recycled, even an old PCI slot video card from the pre-AGP era, you could diagnose this. At least in the past some thrift stores had old computer parts. Check out thrift stores, electronics recyclers, or any other source you can think of (craigslist "free" listings) for old computers being thrown out as a source for old parts suitable for test swapping.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •