windows will not assign drive letter to USB device
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 5 of 5

Thread: windows will not assign drive letter to USB device

Hybrid View

  1. #1
    Join Date
    Apr 2007
    Posts
    81

    windows will not assign drive letter to USB device

    I have a PATA hard disk (WD 3200) that is not installed in a computer. I bought a SABRENT converter that powers the drive, reads it, and outputs to a USB2 connector. When I connect the USB cable to either my Windows 7 or Windows 8 computers, there is no drive letter assigned and I cannot find a way to read the drive. I can use the "eject" feature of Windows to see that the drive is connected. When I connect the USB cable to my Linux (Mint) computer, it recognizes the drive and allows me to open it and manipulate the contents (there are three partitions).

    Is there any way to make either of the Windows versions assign a drive letter to my drive? Any ideas as to why this only works with Linux? The drive is formatted with NTSF.

  2. #2
    Join Date
    Oct 2000
    Location
    Dallas, Tx.
    Posts
    2,668
    START-> Run and type-> diskmgmt.msc

    What is the status of the drive? Or is it even seen?
    "Imagine a world where dogs took bad owners to the pound."


    http://www.hopeforpaws.org/

  3. #3
    Join Date
    Apr 2007
    Posts
    81
    When I start diskmgmt.msc, Win8 shows the disk and its three partitions. When I right-click on any partition in it, the options are grayed out, leaving only "delete" as an option. When I do this with the directly installed disks, I can open any partition by right-clicking and selecting "open." When I open a file browser, there is no letter displayed.

  4. #4
    Join Date
    May 2006
    Location
    Arkham Asylum, Cell 13
    Posts
    3,385
    What about in Linux? What does the partition manager say there? Are you sure it is NTFS?

  5. #5
    Join Date
    Apr 2007
    Posts
    81
    Midknyte - Thanks. You got it. I hooked the drive up to the Linux machine again and found that the partitions are marked ext3/ext4. I suppose I need to either reserve the drive for my Linux computer, or reformat it to NTFS.

    I suppose this thread can be marked as resolved. Thanks again.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •