[RESOLVED] External Hard drive
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 5 of 5

Thread: [RESOLVED] External Hard drive

  1. #1
    Join Date
    Feb 2008
    Posts
    3

    Thumbs up [RESOLVED] External Hard drive

    Hi to everybody. I am new to this forum just got here from newegg.com

    Like most people over here I am having a problem. I just bought a Toshiba harddrive 120G SATA (see link) and an external case for it (see link). I assembled the two together and when I plug it to my computer, I get the message that it detected the new hardware and installed the components but I cannot access it (there is no icon under My Computer).

    If anybody has any experience with this I would really appreciate your help.

    Thanks

    AntonLX

  2. #2
    Join Date
    Dec 1999
    Location
    Augusta, Georgia, USA
    Posts
    3,944
    You are going to need to partition and format the drive.

    Go to Control Panel/Administrative Tools/Computer Management/Disk Management. You should see the disk there. Right click on it and set it up.

  3. #3
    Join Date
    Feb 2008
    Posts
    3
    Thanks for the quick reply. I'll try it once I get home since I don't have administrative rights on my work PC.

  4. #4
    Join Date
    Dec 1999
    Location
    Augusta, Georgia, USA
    Posts
    3,944
    Post back and let us know if that solves your problem. Thanks.

  5. #5
    Join Date
    Feb 2008
    Posts
    3
    jimbo1763,

    Thanks for the help, it worked. It took me a few minutes to figure out the whole setup (new to Windows Vista) but I got it at the end.

    Thanks again.

    AntonLX

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •