My problem:
Windows Explorer doesn't see my IBM 120 GB HDD (Model IC35L120AVVA07-0) although Device Manager tells me that it is working properly.

The Background:
The 120GB HDD was installed as the 2nd HDD in my old PC running Win98SE. Ontrack DDO was installed so that the full capacity of the drive could be used.

I replaced that PC 18 months ago. This runs Win XP Home SP2 and has 2x200Gb SATA HDD configured as RAID 0. Since that is now nearly full I want to add the 120GB HDD to my new PC. I don't care about the data on it, anything I wanted was copied over ages ago.

The ASUS A8V motherboard allows one to mix SATA and PATA drives.

I installed the drive, re-booted and the new drive was recognised as Drive F:, unformatted. I formatted it but the only capacity option was 32GB. It worked as a 32GB drive - I copied a small folder of music to it and played that music. The BIOS only sees it as 32GB capacity.

Quite obviously, the initial part of DDO that tells the BIOS that the 120GB HDD is only 32GB is still in place and I've got to get rid of it before I can get the full capacity back. Both the floppies containing the original Ontrack s/w are reported as corrupt now

I downloaded Hitachi's DFT (Drive Fitness Test (v4.07)). I'm as sure as I can be that it recognised my HDD as 120GB that first time. I ran the Quick test and it passed, then zeroed the MBR in an effort to remove the DDO. That didn't work and left me unable to see my 120GB HDD in Windows Explorer even though Device Manager tells me that it is working properly. I uninstalled the driver and rebooted. Windows XP saw that new hardware was installed but no joy. Both the BIOS and DFT see the 120GB HDD as 32GB now.

From All Programs|Accessories|System Tools|System Information|Components|Storage|Drives the 120GB HDD is not listed.

From All Programs|Accessories|System Tools|System Information|Components|Storage|Disks the 120GB HDD is shown as 31.49 GB (33,814,126,080 bytes) and 512 Bytes/Sector.

I've run out of ideas - is anyone able to help me please?