DVD Drive thinks its a CD Drive
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 11 of 11

Thread: DVD Drive thinks its a CD Drive

  1. #1
    Join Date
    Nov 2005
    Posts
    5

    DVD Drive thinks its a CD Drive

    Please help me. I'm stumped.

    I only recently bought the Philips DVD Rewriter PBDV16LSB and it's been working fine, burning DVD's etc.

    Now suddenly it will play DVD's but when I put a blank one into the drive the DVD/RW (E icon changes to a CD Drive (E for no apparent reason and when I double click on it is says the the drive in inaccessible.

    I have no idea how to deal with this and Philips won't help me.

    Can someone help??

    Many thanks

    Shark

  2. #2
    Join Date
    Apr 2004
    Location
    San Jose, CA USA
    Posts
    313
    I had the opposite problem a few months ago: my Plextools utility thought that my CD reader was a DVD drive. I fixed it like this:

    1) Uninstalled both drives in Device Manager and Plextools from Add/Remove programs. Shut down PC.

    2)Disconnected the CD reader (removed power cable). Reboot.

    3)Reinstalled Plextools. Shut down PC.

    4) Reconnected CD reader. Reboot.

    Basicly, make sure your DVD drive is the only removable drive in your PC when you install it. It will help prevent Windows from getting confused.

    This worked for me.

    t-man
    A64 3500+
    Asus A8V Deluxe
    Antec 480W Trupower II
    2 X Corsair CMX512-3200C2PT
    PNY 6800GT
    Turtle Beach Santa Cruz
    Plextor PX-716SA DVD/CD burner
    Memorex 52X CD reader
    Western Digital 300GB IDE
    Maxtor 300GBSATA
    Seagate 300GB SATA
    W2K Pro

  3. #3
    Join Date
    Nov 2005
    Posts
    5
    Hi T Man,

    Thanks for the advice but I'm a bit of a novice so I'm not too sure I follow. I don't have Plextools (not sure what that is) and I can't disconnect the drive because its internal.

    I've tried rebooting my computer. Should I disable the drive and then reboot?

    "Basicly, make sure your DVD drive is the only removable drive in your PC when you install it. It will help prevent Windows from getting confused."

    I'm not sure how to make the DVD drive the only removable drive.

    Sorry for being dumb.

    All the best

    Shark

  4. #4
    Join Date
    Apr 2004
    Location
    San Jose, CA USA
    Posts
    313
    You won't have Plextools: it comes with Plextor CD/DVD drives (that's what I have). It's irrelevent to your problem, sorry for the confusion.

    I realize that your drive is internal: I assumed that you installed it yourself. I'm not so sure now ;-)

    Anyway, if you try my idea you'll have to open up the PC case and remove the power connector (or the IDE Cable) of your CD drive. This will prevent your computer from "seeing" the CD drive. You can now install the DVD drive without any possibility of the drivers getting mixed up by the New Hardware installer.

    Let me know if this isn't clear.

    t-man
    A64 3500+
    Asus A8V Deluxe
    Antec 480W Trupower II
    2 X Corsair CMX512-3200C2PT
    PNY 6800GT
    Turtle Beach Santa Cruz
    Plextor PX-716SA DVD/CD burner
    Memorex 52X CD reader
    Western Digital 300GB IDE
    Maxtor 300GBSATA
    Seagate 300GB SATA
    W2K Pro

  5. #5
    Join Date
    Nov 2005
    Posts
    5
    Hi again.

    Ok, well that makes more sense.

    I did install the drive myself, with some difficulty.

    so let me see if I get you:

    1. Disable the CD drive and the DVD drive in device manager.
    2. Shut down
    3. Unplug the CD drive IDE
    4. Reboot
    5. Enable the DVD drive and see if it's working.
    6. Get the CD drive back on
    Am I there yet?

  6. #6
    Join Date
    Apr 2004
    Location
    San Jose, CA USA
    Posts
    313
    Almost, except for #1. You should delete the drives from the device manager, not disable them. Then shut down and disconnect CD. When Windows restatrts it will redetect your DVD and install any drivers that are needed, but the CD will be undetected because it's powered down. Now shut down the system again and reconnect the CD, then restart. Windows will now detect the CD and install it.

    t-man
    A64 3500+
    Asus A8V Deluxe
    Antec 480W Trupower II
    2 X Corsair CMX512-3200C2PT
    PNY 6800GT
    Turtle Beach Santa Cruz
    Plextor PX-716SA DVD/CD burner
    Memorex 52X CD reader
    Western Digital 300GB IDE
    Maxtor 300GBSATA
    Seagate 300GB SATA
    W2K Pro

  7. #7
    Join Date
    Sep 2000
    Location
    Memphis Tennessee
    Posts
    4,930
    Some Rewrite drives do not work well on the Slave IDE channel. They want to be on the Master Channel.

  8. #8
    Join Date
    Nov 2005
    Posts
    5
    Thanks T Man,

    That makes perfect sense.

    I'm going to give it a go and let you know.

    Regards

    Shark

  9. #9
    Join Date
    Sep 2000
    Location
    Memphis Tennessee
    Posts
    4,930
    when I put a blank one into the drive the DVD/RW (E icon changes to a CD Drive (E for no apparent reason and when I double click on it is says the the drive in inaccessible.
    I think this is part of an Anti Copy scheme. It may be just a file structure deal. If the RW disk is blank, it will not show up as a DVD. Record something on the disc and it will show up as the correct drive and the data would be available.

  10. #10
    Join Date
    Nov 2005
    Posts
    5
    Hi Leo,

    That's all very well but I want to actually record onto the blank disk and when it's in the drive, it says that the drive is inaccessible.

    Will be taking my computer apart tomorrow to try out the Turtle plan.

  11. #11
    Join Date
    Sep 2000
    Location
    Memphis Tennessee
    Posts
    4,930
    What software do you burn with? If you launch Nero for instance, it should see the blank RW media.

    Still, Turtle Man's advise is sound.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •