Quality PSU's besides Enermax - Page 2
Home | Reviews and Features | Special Reports | Forums |

Page 2 of 2 FirstFirst 12
Results 16 to 19 of 19

Thread: Quality PSU's besides Enermax

  1. #16
    Join Date
    Dec 2002
    Location
    Redmond, WA
    Posts
    1,206
    I can't complain about my Antec TrueBlue 480W. Perfect rails since day one. The sucker wasn't cheap, though - $80 for a PSU certainly made me cringe.
    Opteron 165 @ 280x9 = 2.52GHz
    ASUS A8N32-SLI Deluxe
    BFG 7600GT OC
    Corsair 2GB DDR400 Dual Channel
    Seagate Barracuda 200GB SATA
    NEC 3500A 16X DL DVD±RW

  2. #17
    Join Date
    Dec 1998
    Location
    Grand Haven, Michigan, USA
    Posts
    11,332
    Yah I think the PS is OK and the motherboard sucks. I put the 480w True Blue in one of my Abit NF7 systems and it reports 11.92 volts. That is a bit better I think. I'm very tempted to dump this board (and never touch MSI again. Maybe I'll get an Abit NF7-S as they have dropped down to about $10 from the regular NF7 prices. It used to be around a $20 premium. I've just been very happy with my Abit boards over the years and now do not like Epox or MSI.

    My B-Day is coming up, but I just bought a DVD player from Philips that plays DivX too. Best Buy online had it for only $80. I expected it to be pretty cheap, but I am actually pretty happy. It plays pretty much all my (many) movies on DVD or DivX (or Xvid). I'm not really to keen on dumping another $80 on a new motherboard.
    AMD Phenom II x4 945 3Ghz | ASUS M4A77TD | 2X WD 1TB SATA 2 hard drive | 2x2GB Corsair XMS3 | nVidia GeForce 8800 GTS | ATI TV Wonder Theater Pro 550 | Antec P-160 case | Antec 650w Earth Watts | LG Blu-ray Super Drive | LG DVD RW | Windows 7 Pro

  3. #18
    Join Date
    Feb 2002
    Posts
    3,265
    Same with DFI NF2 Ultra Infinity, I have
    mobo sensor shows about 0.30V lower 12v rail as it is in reality and its been acknowledged as a common problem on the DFI forum

  4. #19
    Join Date
    Dec 1998
    Location
    Grand Haven, Michigan, USA
    Posts
    11,332
    Butr this is more. I get 11.55v on my MSI and 11.92v on my Abit NF7. That .37v... OK so its only a little worse than yours, but that is rediculous... and pisses me off. I'm just not sure what to do about it though as the board is out of warrenty and I don't really want to RMA the PS anymore as it will likely take 6 weeks to get it back. I think I will just leave the 430TP in my main system as it does run .06v higher (but .13v higher in the Abit system). I think I will stick with Abit or maybe ASUS for a while.

    On a side note I just got a Philips DVP642 DVD player at Best Buy for $80. The cool thing is this will play all my DivX (and Xvid and MPEG 4...) movies too. It works just great and has optical audio outputs to hook to my 600w suround sound system. I got it yesterday and it works even better than I expected. It plays everything perfect. It is my first DVD player (not in a computer). My VCR died, so I am borrowing one to copy the tapes I do not already have a DivX copy of through my Radeon 9700Pro AIW (boy that video soap is cool looking). It was my fathers day pressent!
    AMD Phenom II x4 945 3Ghz | ASUS M4A77TD | 2X WD 1TB SATA 2 hard drive | 2x2GB Corsair XMS3 | nVidia GeForce 8800 GTS | ATI TV Wonder Theater Pro 550 | Antec P-160 case | Antec 650w Earth Watts | LG Blu-ray Super Drive | LG DVD RW | Windows 7 Pro

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •