[RESOLVED] New Power Supply for Celeron 500 system
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 3 of 3

Thread: [RESOLVED] New Power Supply for Celeron 500 system

  1. #1
    Join Date
    Mar 1999
    Location
    Melvindale, MI
    Posts
    76

    Thumbs up [RESOLVED] New Power Supply for Celeron 500 system

    The power supply in my parents' Celeron 500 system recently blew (apparently a transistor blew up inside and took out several other components inside the power supply), and I need to get them a new one. It's in an ATX case, running on a Tyan motherboard that's about 2-3 years old (I think the Trinity 1854). Any reason why I couldn't get them a new Antec SL350 power supply?

    Thanks for your expert help!
    "Do not meddle in the affairs of Dragons, for thou art crunchy and good with ketchup."

  2. #2
    Join Date
    Dec 1998
    Location
    Nottingham Uni, England
    Posts
    1,945
    no reason at all why you couldn't, it is a bit overkill though. A Celery 500 should be perfectly happy with a 250W PSU....unless you're planning to upgrade their system anytime soon that is.
    AHHH, I think my computer's got a Virus!

    Oh no, that's Windows XP

    Chimaera: Twin Athlon MP 1900+ @ 1824Mhz, GeForce 3 TI500, 512Megs Crucial RegECC, 100GB Total HDD, SuSE Linux 7.3 + Windoze XP Pro

  3. #3
    Join Date
    Mar 1999
    Location
    Melvindale, MI
    Posts
    76
    Well, a 250W is what blew, so I figured a bit more wattage wouldn't hurt anything...
    Thanks for the reasurrance

    PTsGyrl
    "Do not meddle in the affairs of Dragons, for thou art crunchy and good with ketchup."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •