Windows 2000 HLT commands
Home | Reviews and Features | Special Reports | Forums |

Results 1 to 5 of 5

Thread: Windows 2000 HLT commands

Hybrid View

  1. #1
    Join Date
    Feb 2000
    Location
    Manchester, England, UK
    Posts
    2,560

    Windows 2000 HLT commands

    Sorry I havent posted in a while, but ive been gettin my website up to scratch. If you want, you can visit it at http://andywalkeronline.tk

    Ive just modified my profile and signature with my newish specs.

    Anyway, after building a machine for a mate, I got hold of her old parts. A K6-2 400, motherboard, RAM and case.

    My Cyrix 333 @ 366 is acting as a dedicated server for Counter-Strike and UT for my LAN.

    My question is, does Win2000 have support for HLT commands during idle times on the processor. In Windows 98/ME I use a small program called Rain to keep the processor cool during idle.
    I read in the readme for Rain, that NT has its own HLT cycles built-in, but after having the machine on idle for 20 minutes and touching the heatsink, I thought better. The heatsink was hot.

    Is there a similar program to Rain for NT based systems, as the Cyrix system is built in an AT case and has a Voodoo3 3000 and so, it gets rather hot even with a fan at the front of the case.

    Thanks in advance
    Andrew
    Desktop - XP2100 @ 2.4GHz, Abit NF7-S, 1gb DDR500 Crucial Ballistix, 120 + 160gb HDD, Windows XP
    Laptop - Athlon 64 3000, 1gb RAM, 40gb HDD, Radeon Mobility 200, Windows Vista
    Server - P4 1.8GHz, 768mb RAM, 2x 40gb HDDs, Win2k3 Server

  2. #2
    Join Date
    Nov 2000
    Location
    Connecticut
    Posts
    6,459
    What chipset is the motherboard sporting? You can use wpcrset to enable the halt command (aka cooling bit) via hardware registers in the BIOS (you do this from Windows though). No version of Windows has this enabled because oftentimes it results in a sluggish system or instability- and the hex value of the bit varies from chipset to chipset. Windows does cool the processor somewhat (a few degrees) when compared with reading the temperature from within the BIOS. Some motherboards have the cooling bit automatically enabled in their BIOS, but it's very rare to see this. You could try out vcool if the chipset is a VIA, or cpucool which works more universally. These do the same thing as using wpcrset but offer a temperature display and use more memory (wpcrset uses none).
    My Guitar Hero 2 Xbox Live Ranking
    Main Rig (click this link for specs)
    Certified in: Nothing at all!
    Certifiable: 100% hands-on, real-world experience

  3. #3
    Join Date
    Feb 2000
    Location
    Manchester, England, UK
    Posts
    2,560
    The motherboard is a PC-Chips TXPro II M571LMR and has the TXPro II M571 chipset. Crappy, but cheap enough for my first socket 7 system all those years ago.

    I have looked in the BIOS but it is very basic compared to some of the systems I have built.

    I have gone to Windows 98 until I find a program because even though Windows 2000 ran well on this machine, it just got too hot.

    Thanks for posting
    Andrew
    Desktop - XP2100 @ 2.4GHz, Abit NF7-S, 1gb DDR500 Crucial Ballistix, 120 + 160gb HDD, Windows XP
    Laptop - Athlon 64 3000, 1gb RAM, 40gb HDD, Radeon Mobility 200, Windows Vista
    Server - P4 1.8GHz, 768mb RAM, 2x 40gb HDDs, Win2k3 Server

  4. #4
    Join Date
    Sep 1999
    Location
    Ontario Canada
    Posts
    1,349
    cpuidle should do the trick for ya
    Go ahead...... lick my BLOCK
    This is my website

  5. #5
    Join Date
    Feb 2000
    Location
    Manchester, England, UK
    Posts
    2,560

    CPUidle

    Cheers, I actually downloaded CPUidle for NT a few days ago but I cannot be bothered to format that machine and put 2000 on it again.

    Can you blame me? Ive just got a 40gb seagate hard disk and so am spending huge hours installing all that software. LOL

    Ill put it on later this week and let you know how its going.

    Thanks all
    Andrew
    Desktop - XP2100 @ 2.4GHz, Abit NF7-S, 1gb DDR500 Crucial Ballistix, 120 + 160gb HDD, Windows XP
    Laptop - Athlon 64 3000, 1gb RAM, 40gb HDD, Radeon Mobility 200, Windows Vista
    Server - P4 1.8GHz, 768mb RAM, 2x 40gb HDDs, Win2k3 Server

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •